Conversations

Photo of Andrew Soulnice Parker
DJAY version 4.2.2 outdated
I cannot open my DJAY application version 4.2.2. Message says Cannot open cause it has been damaged. Remove to Trash go to appstore and d...
  • 2 me toos
  • 3 replies
  • Problem