Beatport unable to load track

  • 2
  • Problem
  • Updated 2 weeks ago


Super excited to see the Beatport Link integration.

I've just been browsing the top 100 lists after activating my Beatport subscription from within DJay Pro 2 on Mac and I'm unable to load any tracks.

It comes up with "unable to load track", " there was a network error downloading the Beatport track (11).

No problems with network access on anything else on the computer or within DJay, using latest versions of software and OS.

Any help gratefully received.

Photo of Dj Retina

Dj Retina

  • 11 Posts
  • 1 Reply Like

Posted 2 weeks ago

  • 2
Photo of Lukas E

Lukas E, Official Rep

  • 4226 Posts
  • 439 Reply Likes
Hi Dj Retina, Thank you for getting in touch and your interest in djay Pro 2 with Beatport. I am sorry to hear about the Beatport issue. Could you make a screenshot of the error? Have you tried logging out and back into your account in djay (library > log out of Beatport (username))?
Photo of RakanIam


  • 60 Posts
  • 13 Reply Likes
Same issue. Tried to log out and in to no avail.