Pre-Cueing not working on DDJ-SX2

  • 3
  • Problem
  • Updated 5 months ago
I have been using DJ Pro, I have a MacBook, for the last 2 years, I love it...however with this last update, I can't pre-cue anymore....any suggestions or anything would help!!
Photo of DJ Rare Being

DJ Rare Being

  • 4 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 3
Photo of Victor Damian

Victor Damian

  • 45 Posts
  • 15 Reply Likes
I have an SX2 as well. I have no issues pre-cueing. Just to be clear. Are you referring to headphone pre-cueing?
Photo of DJ Rare Being

DJ Rare Being

  • 4 Posts
  • 0 Reply Likes
Yes the headphone pre-cue
Photo of Lukas E

Lukas E, Official Rep

  • 4157 Posts
  • 416 Reply Likes
Hey there,

thank you for your post.
The Pre Cueing should work after accepting the midi mapping dialog window after start up.
Have you checked all Pre Cueing related knobs on the SX2?

Cheers,
Lukas E.
Photo of DJ Rare Being

DJ Rare Being

  • 4 Posts
  • 0 Reply Likes
So it's definitely the DJPro software. Just tried it on Serato and it's working fine.
Photo of Douglas Andres Antepara

Douglas Andres Antepara

  • 1 Post
  • 0 Reply Likes
Just purchase the sx2 and am having that problem too, pre-cue worked fine on my sb2 but not this better mixer, I need help
Photo of DJ Rare Being

DJ Rare Being

  • 4 Posts
  • 0 Reply Likes
I will check this today and update you. I haven't changed anything...it connects when I connect it...everything else works but that...even the master cue works
Photo of Lukas E

Lukas E, Official Rep

  • 4157 Posts
  • 416 Reply Likes
Contact us right away.
Our device at the office is working flawlessly, I am sure we will find a solution for this issue.

Cheers,
Lukas E.
Photo of Ryan

Ryan

  • 3 Posts
  • 0 Reply Likes
Was this issue resolved? I am having the same issue. I can hear the Master Cue through the headphones but I can't pre-cue.
Photo of Lukas E

Lukas E, Official Rep

  • 4157 Posts
  • 416 Reply Likes
Hey Ryan,

can send me images of your controller and a screenshot of your audio device settings via support@algoriddim.com?

Thank you in advance.

Cheers,Lukas E.
Photo of Antonio Scribano

Antonio Scribano

  • 1 Post
  • 0 Reply Likes
Hello guys,
same problem here.
A.
Photo of Iain Clarke

Iain Clarke

  • 2 Posts
  • 0 Reply Likes
Was this ever resolved? I'm having the same issues, DDJ SX, no cueing, can only hear the output.
Photo of Lukas E

Lukas E, Official Rep

  • 4157 Posts
  • 416 Reply Likes
Hi Iain,

the SX and the SX 2 are natively supported by djay Pro for the Mac.

All you need to do is connecting the controller and accept the audio device setup window.

If you have any questions or suggestions, or if you would like further information, please don't hesitate to contact us. 
Photo of David Kirsner

David Kirsner

  • 12 Posts
  • 0 Reply Likes
I am also, all of a sudden, unable to pre- cue! I used to have no issue. I am using ddj sx. Pls help guys!
Photo of Si

Si

  • 3 Posts
  • 0 Reply Likes
I've got this issue too. Please help!
Photo of Paul

Paul

  • 2 Posts
  • 0 Reply Likes
Same problem here. On my DDJ-SX I can hear the master on headphone, but not cue. Tried Serato software and other software, no problem.
Photo of Lukas E

Lukas E, Official Rep

  • 4157 Posts
  • 416 Reply Likes
Hi Paul, make sure your Pre Cueing settings in djay Pro and on your SX are not set to MASTER the full way.

If you have any questions or suggestions, or if you would like further information, please don't hesitate to contact us. 
Photo of rico utoro

rico utoro

  • 2 Posts
  • 0 Reply Likes
Hi Lukas,

Could you please be more detail on the process (step by step details)?

Cheers Bro
Photo of rico utoro

rico utoro

  • 2 Posts
  • 0 Reply Likes
Fellas,

For a temporary solution, you could use "internal mixer mode", main output : pioneer ddj (any midi controller type), pre-cuing "build in output", and plug your headphones to your laptops..

Step by step (mac version):
1. Open "preferences"
2. Click "devices"
3. Select "internal mixer mode"
4. Select main output "pioneer ddj (or any kind of midi controller)"
5. Select pre-cuing "build in output (or any internal output from your laptop)"
6. Plug your headphones / headset to your laptop

Note:
- I don't have the windows version tutorial (but you can apply the same method)
- For cue on off, click the "headphone icon", usually near the crossfader

Hope this temporary solution helps till algoriddim resolve this problem..

Cheers =)