Audio mapping failure


Macbook Pro 17 2.8Ghz w/ terabyte drive, 8G ram
Pioneer DDJ-SX2

I use the Pioneer for main output and pre-cuing.

Three times in a set last night, the audio cut out on the pioneer and re-routed through main out (internal speakers) on the mac. The first time I disconnected and reconnected the Pioneer and then remapped. The next two times, I immediately just remapped and the audio came back on.

This is highly concerning. I’m certain that I didn’t jostle the USB cable to cause a disconnect. The first time, I was mixing some cues in from the second deck off the triggers, but the other two times I wasn’t touching anything.




Yes, the one supplied by Pioneer and the one that I had in my road case.

Is there a log I can access to provide to you and/or Pioneer that shows when the software audio cut occurred? If it is a mechanical circuit break on the USB channel, I realize neither you or Pioneer can help, but like I said in the original post, there was nothing happening. I didn’t touch a thing. I just reassigned the ports and it popped back up… I’ll get a bottle brush and clean the USB links if you that makes sense. THREE audio blackouts in one show.

Hi there,

our apologies for the audio setting changes.
Have you tried to connect the SX2 via another USB cable?

Thank you in advance.
Lukas E.

Hi there,

thank you for the response, first off, could you please check this step by step guide on how to avoid audio dropouts?

If you are experiencing audio dropouts or other issues while mixing with djay Pro, we recommend you several steps in order to optimize your djay Pro performance.

  1. Keep your OS X and djay Pro updated.
  2. Check if your controller is running with the latest firmware.
  3. If your Mac is using a non-SD hard drive, disable the Sudden Motion Sensor
  • Double-click on the Macintosh HD icon on your desktop (this would be your system drive if you have renamed it to something else).

  • Go to the Applications folder.

  • Go to the Utilities folder.

  • Double-click on Terminal.

  • Type sudo pmset -a sms 0 and press Return (typing in ’0′ disables it).

  • Enter your administrator when prompted.

  • Type sudo pmset -g to verify that this has been applied. To re-enable Sudden Motion Sensor:

  • Go back to Terminal following the above steps.

  • Type sudo pmset -a sms 1 and press Return (typing in ’1′ re-enables it).

  • Enter your administrator when prompted.

  • Type sudo pmset -g to verify that this has been applied.

  1. If you connect an external hard drive right before mixing, please wait till the Spotlight indexing is being finished
  2. Check your USB cable or try with another cable.
  3. Make sure your USB cable is connected to the “good” USB port, see

If this is not helping please contact us right away.

Lukas E.