Brand new DDJ-WeGo3 does nothing when connected to Macbook by USB - help?

I have connected my brand new DDJ-WeGo3 to my Macbook using a USB cable and I have launched djay PRO on my Macbook but nothing happens. My Macbook doesn’t recognize the DDJ-WeGo3 or acknowledge that anything is plugged in. Any ideas? I was expecting that as soon as I plugged the DDJ-WeGo3 into the Macbook, it would work or at least offer some functionality. It’s not a bad USB cable - I have tried 3 different ones. Is my DDJ-WeGo3 bad out of the box?

Thanks for the reply Lukas. Yes the controller’s power light is on and it gives me a pretty light show, but nothing else.

Thanks for the replies. Lukas I will send the video tonight. Daniel I am not using a hub - I am plugging directly into the Macbook, but that was a good thought. I think either (a) the WeGo is bad, (b) whatever the little software routine is that allows most Macbooks to automatically recognize the WeGo is bad / corrupted / missing on mine, or (c) all three of the USB cords I have tried are bad.

Is it possible you are connecting it to a USB hub? I know my USB hub has 2 ports that are power only.

Hi there,

this sounds odd, the WeGo 3 is supported natively and all you got to do is connecting the controller and turn it on.
Is the controllers green power light shining?

Lukas E.

Thank you for the reply. Can you send us a video connecting the WeGo to your Mac via

Thank you in advance.

Lukas E.