Cue/mix slider and cue A/B problems with Djay2 and Wego3

Hi, I’m using wego3 with djay 2 on an iPad mini air.

If I have the Master button lit, i can still hear a song in the headphones on Deck A, if the Cue light for Deck A is on and cross fader panned all the way to B (or vice versa. (no difference if master is on or not, I always hear cue mix)

I can adjust the cue/mix slider and set it 100% to mix but the problem is sometimes this setting sets itself to 50% when you move cross fader all the way back and foth left and right and the Cue A and cue B lights go on by themselves.

Is there a way to turn off the automatic turning on of Cue A and B when moving cross fader back and forth and also is this is a bug making the cue/mix slider reset itself to 50%?


Edit: the latest update has a preference to turn off the headphone auto cuing. Thanks.