Djay not recognizing Numark Mixtrack Pro

hey there.
I suddenly have an issue with Djay connecting with my Numark Mixtrack Pro.

I have a mac running OS X 10.9.5 and running Djay 4.2.3
I started up Djay, and it took a long time to be up and running. The program would open, but displays a spinning rainbow for about 3-4 minutes before being usable.

When I plug in my Mixtrack Pro, it initially recognizes it and confirms that I’d like to use it for audio output as well as pre-cueing. After ok’ing that, and the audio engine reconfiguring, the Mixtrack controls don’t work at all. Clicking on the MIDI tab it says “No Devices Found”… BUT, i’m still able to run my audio out to a mixer via the Mixtrack Pro.

Any ideas? I reinstalled the program via the app store (I had previously bought it with a license from the Algoriddim site), but still no luck. Kinda losing my mind! Love the program, but I’m out of tricks.

Thank you!


I’m having this same issue after the update from the app store. Before the update everything worked, it seems that the midi functionality stopped working completely.

Hi Patrick,

Have you tried using a different USB cable or port?

As an experiment, please see if your controller works with the “MIDI Monitor” app:

I tried a different port on my computer, but I don’t have another USB cable with the same connection. The Mixtrack Pro lights up when I plug it in, and I was still able to use the RCA outs on the Mixtrack Pro to act as the main output. Do you think the cable could still be an issue?