djay2 for iPhone does not recognize WEGO4

djay2 for iPhone (ver.2.8.3) on iOS10 (10.1) does not recognize WEGO4.

If you have not already try all these approaches.

1.) Plug in Wego then start Djay 2
2.) Start Djay 2 then plug in Wego
3.) Hot plugging while Djay 2 is running

Make sure you move platters, faders, press some buttons etc with every attempt as sometimes it will prompt things to activate.

Hi tosh,

we are sorry to hear that, can you tell us which djay version you are using?

Lukas E.

Hi tosh,

sorry for the misunderstanding. Can you tell us how you are connecting the WeGo4 and if your iPhone is charging?
Also there is an app called “midi wrench” which allows you to see midi events triggered with your WeGo, please download the app and tell us if midi signals are being transferred.

Lukas E.

Thank you for the follow up, can you contact us via

Lukas E.

Dave, many thanks.
I tried all three, pushing buttons and moving platters and faders, but no luck unfortunately.
Can anyone help?

I tried with rekordbox dj and it worked.

Lukas, thanks!
Pls refer to my first post above.
It’s 2.8.3.

Lukas, thanks again.
My iPhone 5s is connected to WEGO4 with a simple USBLightning cable.
Haven’t heard of Midi Wrench, so will check it and get straight back here, but I assume the problem does not directly relate to Midi data transfer, as djay2 works perfect when WEGO4 is powered by AC adopter. The problem happens only when the power is supplied by mobile battery (5V/2.1A) via USB…

Lukas, I downloaded Midi Wrench and checked my WEGO4 with it, and seems all the actions and movements of the controller are detected correctly.
Seems the iOS app doesn’t have the function to export logs, should I capture the screen and upload here?