Error loading iTunes library.

Error loading iTunes library.

Anytime I try to open up Djay I get this error:

I’ve deleted the file from iTunes and the physical file, I’ve even deleted iTunes Library.xml and I still get this error. I have no idea how to fix this. Any ideas?

On a MacBook Pro laptop I’ve had issues with djay reading the iTunes Library.xml file. For me (and others) the issue turned out to be oddly related to having Time Machine local snapshots enabled which will be the case if you have TM enabled globally. What happens is that after a while the iTunes Library.xml file is no longer readable which prevents apps like djay from working properly. iTunes will also start leaving a bunch of Temp File.tmp files around in Music/iTunes. Disabling TM local snapshots stops this behavior. Unfortunately Apple doesn’t provide a control for this in the TM system prefs screen however you can disable it using a Terminal window and running:

$ sudo tmutil disablelocal

You can tell if TM local snapshots are enabled or not via:

$ defaults read /Library/Preferences/ MobileBackups

If MobileBackups is 1 then local snapshots are enabled.

Hi Adam,

Have you tried restarting djay? Also, did iTunes create or update the iTunes Library.xml file?

Hmm. In this case, please kindly send an email to support(at) so we can troubleshoot the issue together.

Thanks for posting Will, I’ll also keep this in mind for future reference.


Yes, I restarted djay, my computer, and iTunes did create a new .xml file.