Gigaport EX soundcard stopped working on iOS, only ch1-2 work on first connection with app open then 0 channels after app restart.


This issue forced me to turn to the forum because I just tried for hours on end to make it work again, to no avail. I’ve tried every cable combo and powered hub I have around.

The Gigaport EX soundcard used to work just fine, even with my iPhone! I use it in external mixer mode to occasionally add digital playback to my analog setup at home. ch1-2 for deck one and ch3-4 for deck 2. Now, it only works on my Mac.

The channels show up in the configuration tab on iOS but no sound comes out.

iPad Mini 5, iPad Pro M1 and iPhone 14 Pro with latest updates and everything.

It’s been a loooong time since it last worked, I have had to move and other life things made me put that hobby to the side, had to be last summer. I’m 100% sure it all worked back then. Tried around February this year for a birthday party, that didn’t work and I gave up after an hour. Finally found time to try again and I’m now convinced this is a software problem on Algoriddim’s side.

An hour ago I did manage to make it work by goofing around with the options, playing audio in another app then coming back to it djay, worked two times only, only on the ipad pro. wasn’t able to reproduce that since.

Did anyone encounter similar problems recently? Could Algoriddim support look into this please?

USB can be fiddly. Be sure to check this thread.

1 Like