Hercules RMX not recognized by Djay

I’ve been using the Hercules RMX with Djay for years without a problem. I plug it in via USB and Djay automatically recognizes the hardware. I always have to go into preferences to assign the Hercules in each dropbox as the main output, pre cueing, and microphone. It then configures in about 5 seconds and I’m up and running. Lately, I plug in the Hercules and Djay does not even recognize it, as the console flashes the blue led lights assigned to the buttons several times before shutting off completely. It seems others have had this problem as well, and I haven’t been able to find a reliable fix. I have also contacted Hercules website forum as well. Any advice?

Hi, i have the same issue than Joseph Dawson, since i upgraded my os to El Capitan in my macBook Pro 15". My RMX not working anymore with djay. I’ve tried to reboot and chanched the usb cable, but nothing ha^êned.
Thank U for your help

Hi there,

this sounds odd, the Hercules RMX is natively supported by djay Pro, do you have the possibility to check if the controller gets recognised with another USB cable? This sounds like a hardware problem to be honest.

Thank you in advance.
Cheers,
Lukas E.

Would you two tell us which version of djay you are using? Thank you in advance

Hi guys,

it appears the problem was due to a change of the USB timing of the macOS El Capitan.

Taken from the Hercules - Support Website:

OS X: 
Mac OS 10.11 (El Capitan) has changed the USB timing for computers with USB 3.0 ports. Certain devices like the DJ Console Rmx (and sometimes DJ 4-Set and DJ Console 4-Mx) may get disconnect or be no longer detected properly. If you meet this issue, you should update your Mac OS version to OS X 10.11.4.

https://support.hercules.com/en/product/djconsolermx-en/

Cheers,
Lukas E.

Hey Yaman Ugural,

thank you for the feedback.

Can you contact us via support@algoriddim.com for further help?

Cheers,Lukas E.

Since I have a 2009 Model MacBook Pro I am unable to install the latest OS X Sierra. I am currently running on El Capitan 10.11.6. This is how I connect the Hercules to the Mac and it seems to work. I usually turn the computer off. I turn it back on, and as it boots back up, I plug in the Hercules RMX via usb to the Mac. The blue LED lights start to flash (about 3 or 4 times) and then a single blue light in the top left corner remains lit. That’s how I know it is connected. I have used both djay and djay pro with this method and both apps seem to work. Now, if my Mac is already powered up, and I open the either app, plug in the Hercules RMX via USB, something different happens. This is what I don’t understand and why. The Hercules will again flash the LED blue lights, (this time it seems to flash a few more times) and then the light that usually would appear in the top left corner, does almost a final “quick flash” I’ll call it, and they all go out. Then when I choose preferences from the dropbox, I am unable to assign the Hercules as the main output, as it is not recognized. So, for whoever else said that powering down your laptop, and then turning it back on worked for them, it seems like the only solution at this point. Especially if you are at a gig, setting up, and you have no idea where to start to troubleshoot. It’s the only thing I found that works. However, like I said before, for years I was just able to turn my Mac on, plug in the Hercules, and I was up and running in minutes as it recognized it instantly. Like some of the other feedback, the timing issue of the USB was not supported on the software update. And I have no idea what that even means. All I know is that I was used to a plug and play setup, which could have turned into a disaster at a gig had I not done a pre setup days prior to make sure everything ran smoothly. That, I always recommend. Hope some of this helps.

I have had the same problem. I restart my computer and it seems to work.

Version 1.2.1

I bought DJay Pro this week. If I want my Hercules RMX to work, I need to restart my computer every time. If I don’t, the blue lights on the Hercules keep flashing.

Thx

I’m having a similar problem. It started after using Logic Pro and a midi keyboard. After closing down I went and plugged in my RMX and it just continues to flash. I think over night on sleep mode it fixed it, but I tried Logic and it created same issue and I then updated El Capitan to 10.11.3 and since then I’ve not been able to get it to work. I’ve test the set up and mixer on an iMac on an older version OS and it works. So it is either Logic has created some setup which is conflicting with the RMX or that was the initial problem but now the latest El Capitan is causing issues. I feel it is some sort of setup rather than the OS but have no idea how to get the bottom of it.

I have the same problem. But I run a OSX 10.12.13 (sierra) What could be the problem?

I’m very interested in the resolution of this issue. Can you please publish any outcome?

Kindest,
Andreas