iPhone Remote for djay on iPad

@heysoundude here you go!

I’m going to try to find the time to set this up and test it before next weekend…I’ll get back to you with any issues I might find or need explaining.


1 Like

Hey would this work with android phone and djay on iPad…the touchosc app is on play store but hesitant to spend 12£ on it if it only works with iPhone


It should work via Android, but I don’t have an Android phone to test it with. The main challenge I could see is making the wireless connection between Android and iOS. I’m using midimittr on iOS, so I’d check to see if that app is also available on Android first.

Thanks bro

Ah no that’s not on the play store :frowning:

Thanks anyway

@Ben4 you’re welcome. Before you give up, I’d read through the TouchOSC manual and FAQ to see if there’s anything about making a wireless MIDI connection between Android and iOS. Also, the Hexler.com customer support is very responsive so you could simply send them an email.

V4-Update: This latest update includes tabs for the Looper, Sampler and Library controls. New .tosc and MIDI Mapping files can be found in the first post above.

First off, this is an amazing amount of work and such a gift. I just downloaded V4 assets. Thank you, @Slak_Jaw!

My problem: I can’t do the last step of loading the djayMIDIMapping file under MIDI Configs.

I can get my iPhone and iPad to communicate with midimittr that matches the directions here. I’ve also downloaded the djayMINIMapping file to my iPad local Files directory. But that’s where I’m stuck.

When I goto iPad djay > Settings > Midi Devices > [my phone’s bluetooth listing] >MIDI configuration, I only see the same phone Bluetooth item. There’s no way to select the downloaded MIDI mapping file or do much of anything.

Here’s a Dropbox screen capture video to illustrate.

If I select it, I can only edit the name of that bluetooth profile. I can’t delete it even though there’s a way to trash it. If I hit the Play button in TouchOSC nothing happens despite a successful bluetooth connection being reported.

Any idea what’s wrong here?

Running latest iOS 17.1 on both phone/iPad and latest djay v4.1.10 and TouchOSC.

1 Like

Still struggling with getting djay on iPad to see the midimapping file for the iPhone. Mapping file never appears no matter what I do in djay MIDI Config settings.

I’ve repeatedly force-quit djay and restarts of iPad. Not sure what else to try.

Could there be something wrong with the iPhone V4 mapping file so that djay can’t use it? I don’t see any links to download previous versions to test.

Hey @CliffyPop, you’re welcome!

  1. The MIDI Mapping file needs to be copied into the Location: On My iPad>djay folder. Can you please provide a screen shot showing where you have this saved?

  2. Next you need to go to the MIDI DEVICES section NOT the BLUETOOTH section (see below).

  3. From here you’ll be able to load the MIDI Mapping file that you put in the djay folder (see below)

@CliffyPop you’re navigating to the wrong section:

Thanks for replying! In the previous video, I went to the iPad djay Bluetooth section just to show midimittr was connected properly with the iPhone. You can see how there’s no V4 config file selectable in the last few seconds of the video.

Here’s what I’m doing exactly:

I downloaded Slak’s iPhone djay Remote-V4.djayMidiMapping and placed via iPad File app into On My iPad > djay folder. I assume this should make it available to djay on the iPad.

Then, after ensuring midimittr is running on both devices, I’m launching iPad djay, going to settings, and finally MIDI Configurations.

The configuration is never there though. See below in new video.

Screen capture video 2–showing Files app with iPhone midi mapping file


  1. My guess is that you will need to rename my MIDI mapping to CPop’s iPhone 13Pro Bluetooth.djayMidiMapping for it to show up.
  2. Also you could try creating an edit of your existing default CPop’s iPhone 13Pro Bluetooth MIDI mapping and saving it with a different name. Then navigate to the djay folder from the files app to confirm the edit is there.

Ugh, this is challenging. Can’t get it to work still after a couple of methods tried.

Changing the name of your V4 midi map file to match the bluetooth connection label did not work.

With iPad djay MIDI Configuration open and then running your TouchOSC profile on the iPhone, I can get iPad djay to create a new configuration file in On My iPad > djay (it even appended a “1” to the end of its favored filename: CPop’s iPhone 13Pro Bluetooth 1.djayMidiMapping so as not to overwrite the one I renamed from step 1 above).

Moreover on this newly created map file, I can successfully map the movement of iPhone TouchOSC interface onto djay controls and it works across restarts (I mapped the crossfader and deck 1/2 line volume controls to your faders).

Then I tried to move that newly created midi map file to my Mac for editing. I copied all of the data in your iPhone V4 midi map file into the new map file iPad djay just created AND kept the same the filename.

After transferring back to iPad to the same location where it was created at by djay it didn’t work. When I load djay and goto MIDI Configuration, the same CPop’s iPhone 13Pro Bluetooth item appears. If I leave settings and return to djay, now there’s no control anymore.

In other words, I made a config file that worked between iPad and iPhone running TouchOSC. But, once I changed the data in that file with what was in your map, it fails.

Weird and confusing.

@CliffyPop well that is super weird. I would try this.

  1. Duplicate the default mapping then select and rename it to something really simple like “iPad-Remote1”.
  2. Close the djay app.
  3. Within the Files App move my MIDI mapping to a different folder than the djay one.
  4. Then rename it exactly the same as the new mapping you just created.
  5. Finally, use the Move command to move my mapping with the new name back to the djay folder with your mapping.
  6. When prompted, select Replace to replace your mapping with mine.
1 Like

@CliffyPop just following up to see if you were able to get it working? I guess worst case scenario, you can use my TouchOSC layout and do the MIDI Mapping part yourself.

Sorry for delay and big thanks for following up! I just got a new M3 Pro MacBook 14" and was deep into migration (and being sad that Rosetta 2 doesn’t work with a couple of critical older apps I need for work).

Anyway, I finally figured this out! The final statements at the end of your map file has to match what my iPad produces when creating a map file of its own. Otherwise, my iPad djay seems to ignore any external map files.

Here’s what your file has at the end:

	<string>Slak's iPhone Bluetooth</string>

When I create a map file by moving controls on the iPhone when in MIDI Device Settings and then saving, I get a new iPad map file called CPop’s iPhone 13Pro Bluetooth.djayMidiMapping. A couple string items at the end of the new file differs in editor and endpointName like so:

	<string>CPop’s iPhone 13Pro Bluetooth</string>

So, if I take that map file created by my iPad to a text editor and then paste in ONLY the control information between the array tags from your v4 file, and finally put it back to iPad > djay folder, it works.

Here’s a step guide that should work for others (after downloading your files, installing running TouchOSC and its control layout on iPhone, plus getting midimittr communicating on both iPad and iPhone):

  1. Mac plain text editor (like BBEdit or Apple TextEdit in Plain Text mode): open the downloaded Slakjaw .djayMidiMapping file and copy all control instructions between the array tags.
  2. iPad djay: open Settings > MIDI Devices > [user’s device name Bluetooth (or whatever is shown there)]
  3. iPhone TouchOSC: select any control to get the iPad djay to create one new map entry (for example, move the crossfader), map that control to anything, then Save > Done djay Settings.
  4. iPad Files: copy the new map file from On My iPad > djay folder to anywhere on iCloud Drive.
  5. Mac text editor: open the new map file just moved to iCloud Drive and replace all of the control instructions between the array tags with the Slakjaw map instructions copied from step 1 and Save.
  6. iPad Files: copy the iCloud Drive file just modified and replace the map file in On My iPad > djay.
  7. iPad djay: force quit and relaunch. It should now map properly!

Now I’m going to see if I can solve this double tap issue on some buttons like Loops activation. It’s been a couple years, but I think I had a similar issue when I mapped a Novation Launchpad to trigger Loops and Samples in iPad djay. I’l let you know if I turn up any solutions.

1 Like

Hey @CliffyPop, wow that’s odd that the MIDI Mapping files would work differently than with a regular MIDI controller. Glad you were able to get it sorted out and thanks for sharing the steps to make it work! I have linked your post to the original instructions as well with and EDIT.

Now that we’re deep into controlling djay on one device from another, smaller remote device, has anybody thought maybe something like this might be useful/handy/fun/a step up?
The coding work may even be done by apple themselves for it:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.