issues with Recording Sets

I’ve been having problems recording on both DJay algoriddim and also on the Pro version - while the set is playing and I press record it looks like the recording runs throughout the whole set. When I finish and save it, it only saves part of it (randomly)
Any ideas? I use Macbook Pro 2012 (Yosemite) and just upgraded on DJAY Pro but this issue persists. Any ideas?? Thank you

Hi Alex,

Thanks for getting back to me. I’ll try that and see what happens

It seems that this problem is keep coming up

I had the initial version of DJAY and it was recording fine for years and then out of a sudden it started cutting my sets randomly short.

I upgraded to DJAY pro and the same thing happened with the first recording I tried to make - out of 2 hours set it only recorded 5MB and my hard drive has over 200GB left

It is frustrating to say the least as - is this something you can pass on your team for investigation?

Thank you

Hi Stephanos, 

thank you very much for contacting us!
Did you already try to delete the App and then reinstall it? 
Maybe the program is damaged and by reinstalling it this issue could be solved.
Best regards,