Lightning Camera Kit Not Working *UPDATE - FIXED in iOS 16.5.1*

I already tried that and eliminated the possibility of the connection components being faulty. It definately seems to be a software issue.

Hey There SJ, Have you updated to 16.6.1 and not having an issue with the camera adapter?

Just want to know if anyone else is experiencing this issue

Is this with 16.6 0r 16.6.1?
Its working on my Rane One with ipad 9th Gen on 16.6 but haven’t updated to 16.6.1

@maurizio_T I’m still running iOS 16.6 and djay 4.1.9. Everything is working fine with this combo.

Ok Thanks,
I’m on 4.1.10 and it appears to be working fine as well

1 Like

I’ve been thinking it’s probably safe to update to 4.1.10 now. Maybe this weekend…

1 Like

Hi @Beemee, how did you eliminate that possibility if I may ask? In djay itself there is no special handling for the Lightning to USB adapter, and djay will show all MIDI devices that are recognized by the operating system.

In addition to trying another adapter and/or MIDI controller you could also check if you controller shows up in other apps such as a MIDI monitor app like MIDI Wrench or Pioneer DJ’s app.

The camera adapter charges the ipad, can detect USB thumb drives and charge other devices. The same camera adapter worked with the ddj 400 and previous iOS versions. It’s the official Apple model https://www.apple.com/ca/shop/product/MK0W2AM/A/lightning-to-usb-3-camera-adapter.

The ddj 400 works when connected to a laptop. The only thing that has changed are the iOS versions and Djay app versions… currently running iOS 16.6.1 and djay 4.1.10.

I downloaded midi wrench and it displays “DDJ-400 (offline)” in the Midi devices list.

Any other ideas?

Not a DJAY issue then. An OS thing. USB can be tricky, you might want to try resetting your iPad.

Thanks for the suggestion. Resetting the iPad is unfortunately not an option for me as the potential risks and time required to restore data and apps are too great.

@Beemee do you have an iTunes or iCloud backup with the older iOS version that you can roll back to?

Thanks for the suggestion. Unfortunately, I do not have backups with an iOS version prior to 16.5.1.

I’m hoping that the next iOS update will completely resolve the issue.

Might be something you have already tried but have you tried a Hard rest of the iPad?

Sometimes this fixes any glitches and doesn’t cause any loss of data…

I didn’t mean erase. :blush:

You can reset all the settings separately. Also, if you can get your hands on a different USB solution that might be worth a try to (if only for testing).

Can anyone recommend an adapter to try? My iPad needs charges with lightning. I found this adapter which powers via USB-C and has USB and lighting ports - https://www.amazon.ca/Adapter-Lightning-Compatible-iPhone-Drive-Support/dp/B0BNHSKXYT/ref=asc_df_B0BNHSKXYT/?tag=googlemobshop-20&linkCode=df0&hvadid=579075534612&hvpos=&hvnetw=g&hvrand=6903455547778875924&hvpone=&hvptwo=&hvqmt=&hvdev=m&hvdvcmdl=&hvlocint=&hvlocphy=9061023&hvtargid=pla-1945585691250&psc=1

@Beemee I have a USB-C iPad so I can’t help with specific adapters. However, I strongly urge you to stick with official Apple adapters if possible. If you must choose a 3rd party adapter, make sure you get a high quality reputable brand like Baseus or Anker. A lot of these cheap 3rd party adapters simply don’t work with djay.

@Beemee if the adapter you are currently using is NOT the official Apple one, then this is most likely the cause of your current issues.

Seconded. I seriously doubt the one you’ve linked will work fine…

I’m currently using an official Apple adapter and it worked perfectly until recent iOS updates.

Does Apple make a product like the one linked (Amazon link)? Please share links if you know of one that works with a lightning iPad and ddj 400.

@Beemee then I recommend you get another official Apple adapter. It’s possible the one you have is faulty, but based on what you’ve described, it seems more likely iOS related.