Nothing happens for a few seconds after pressing play/pause, switching decks, adding effects, etc. Makes program unusable!

Every action I make, takes about 2-4 seconds to be reflected in audio output…

For example, pressing play.

  • I load a track on deck one
  • I press play
  • The waveform moves and works fine, but I hear nothing out of my MacBook Pro’s headphone jack (also tried it with the internal speakers, same thing happens)
  • About 2-4 seconds later, I get audio

When I go to pause the song, the same thing happens. The waveform stops but the music keeps playing for a few seconds. Same thing also happens when applying an effect; it doesn’t take on the effect until a few seconds after I turned the virtual knob with my mouse.

I deleted the app and reinstalled it from the Mac App store. It has been a few weeks since I last opened djay pro, and today is the first time this has happened to me.

I use djay pro with Spotify mainly but also tried it with my iTunes library and the same thing happens. I then tried just playing a song in iTunes (not using djay pro) and it worked just fine (also works just fine playing from the spotify app on my laptop).

I havent been able to find anyone else online having the same issue, so I’m wondering if it’s me doing something wrong.

Any help would be very much appreciated! I DJ for my buddies at school and school starts in a few weeks!

I have also tried restarting my computer and that did not help