Numark Mixdeck Quad lost control of djay2!

Dear all

Last saturday my equipment let me down severly! After 5 hours performing without any problems I lost control with my Numark Mixdeck Quad of djay2 for iPad (djay2 version 2.5.2., iOS 7.1.2). I wasn’t able anymore to control the volume via the mixer. Also on the iPad directly I wasn’t able to manage the volume either. Volume was frozen and could only be managed via master on the Mixdeck. Crossfader was lost, too. Pre-cuing still was possible. What happend to the system and will I face the same issues next time? What can I do about it. Help is very much appreciated.

Thanks a lot, Ralph

I’m thinking about getting this controller but don’t want to get into the same issues. Can you explain what you did to fix?

Using a lighting to USB adapter-will this still allow for full hardware control over the iPad? I’d rather avoid using the 30pin to lighting adapter if I can.

Hi Ralph,

  • Was the app itself still functioning?
  • Which iPad do you have?
  • How is the iPad connected to the Quad?

When this happens again, please open the Settings app, go to General > About and check if there is still an entry saying “Mixdeck Quad”.

I mean the iPad System Settings app. And this should be done when the problem again occurs. Basically I want to find out if the controller somehow gets “disconnected” when this issue arises.

The fact that the app was still fully functioning most likely points to a hardware issue.

I recommend trying the following setup and see if the same problem occurs:
connect your Quad to your iPad via the normal USB connector + lightning to USB Camera Adapter from Apple.

Hi Warren

Many thanks for getting in touch with me! Yes, the app itself was still functioning. I was able to DJ for the rest of the night. I’m using the iPad 4. The iPad is connected via the cable which came with the quad (30-pin adapteo). As the iPad4 requires the lightning connection I’m using a 30-pin to lightning adaptor.

Which settings do you mean? Those from djay2? I can’t see any entry saying Mixdeck Quad. By the was the iPad is not connected at the moment to the Quad. Does it have to be to get this entry?

Your help is very much appreciated!

Thank you, Warren, great help! I will try the other setup and will let you know about the result!

Hi Jedrzej! No, unfortunately the camera adapter didn’t help. I still face the problem using either iPad or iPhone. I sent the Quad via the retailer back to the wholesaler to get it checked. Even them are not able to define the problem. Although they dedected an issue with the monitoring section, they can’t say that this has an impact on the communication between the Quad and the iOS devices. Strange enough while testing the system Djay freeze did not happen. Beside the offer to fix the monitoring issue, no further support from Numark. I’m still without a clue what to do next.

Hi Matt! The Quad is still a great tool. I appreciate the integrated CD decks a lot. Unfortunately, all of the mentioned fixes didn’t help me to get out of my problem. To be fair, I have to mention, that the problem did not occur again since weeks. It may got resolved with a new release of djay2? I will perform in two weeks for a very long session. This will be quite a crucial test for the system ( I will have fall back options with me). The fact that hardly anybody did know about the problem and was able to help tells me, that the issue is a very seldom and not necessarily a serial one.

It turns out, that the issue is persitent. In the meanwhile I have two controllers with me - a complete back up set up with mixer and laptop. If the IPad is not able to be controled anymore via the Quad I mix with the other mixer. I got used to this workaround very well. In the meanwhile I do restart djay2 and the connection between Quad and djay2 is established again. It’s really interesting, that there is no pattern, when djay2 gets lost. Sometimes after every 2nd track, sometimes it’s working for hours well - and all of this during the same session. For the longterm, I have to say, the Quad won’t be my prefered mixdeck anylonger. Hope to see djay working well together with new high performance mixdecks in the near future. Thanks to all who contributed here!

Hi guys! I used to have the same problem and I fixed it using a lightning to USB camara adapter, no more desconnection but there is a detail… The iPad doesn’t get charge and that is a problem when you are performing for hours. Any solution for this?

Ralph, did it work? Did it happen ever again since you started using camera adapter instead of Numark’s cable? I used to have the same problem once or twice and I wonder if that solution with camera adapter solve it somehow.

Okay, so after yesterday evening it’s clear for me that I give up further tries with Numark Mixdeck Quad and deejay 2. My Numark stopped working with algoriddm software 8 times during 7-hours party. Symptoms - no crossfader, no gains. What’s more, in one of 8 cases crossfader worked, but like upside down - left CF position was assigned to the right deck :wink: I’m considering now to change my iPad software to Traktor stuff, still I’m not sure if the problem lays in the software itself, or somewhere in communication between the two devices. Anyway, for now deejay 2 don’t give me any confidence at all. Not to mention that my colleague (we were playing on two separate devices) was using good ol’ Mixtrack Pro with Traktor LE on PC and everything worked just perfect. Funny, isn’t it? :wink: