Pioneer DDJ RR and Denon MC 3000

I found one, but now I‘m surprised by the SN ratio according to the manual. 70dB seems low? It’s even lower than on my Traktor S2 MK3 (which sounds bad to me)
Or am I getting it wrong?

@Fresh27 I checked the online manual and am seeing the same 70db Signal to Noise ratio. I’m no expert on these specifications, but if your S2 MK3 is higher and you’re not happy with the sound quality and output level, then maybe the VCI-400 is not for you. You’ll also want to look at other specs for the soundcard like Bit Resolution, Sample Rate, Frequency Response and Total Harmonic Distortion as these will all affect the sound quality. However, you can’t always trust the specs alone; testing and listening to it yourself would be ideal.

I’ve never had any issues with mine when connecting the XLR outputs directly into PA speakers, into the club mixer or even into a spare channel on the DJ mixer. I normally just adjust the Trim/Gain on the mixer to get the levels matching the CDJs or whatever else is setup in the venue. I’ve never had any complaints about the output level or sound quality though. I did a quick search and most of the Pioneer CDJs and controllers have S/N in the 110db + range, while the Denon MC6000 is 82db, the MC7000 is 88db and the Prime 4 is 93db. These numbers are clearly all over the map.

Already bought it, so now I’ll try it :rofl:
It seems so strange, cause the reviews about the Vestax often mention the powerful sound. Is your master level on the VCI-400 always maxed at the clubs? I kinda don’t like to use gain on the club mixers.

The difference between 70 and 90db is big, as it doesn’t increase linear from my understanding. Like 140db will not sound double as loud but much much more.

This is the S2 MK3

Hahaaaa okay! Well hopefully you got a good deal and it sounds better than your S2 then.

Why don’t you like to use the input gain on the club mixer channel you plug into? That’s what its there for. To balance out the signal input levels since they are all different. Obviously you don’t want to push anything in the audio chain into the red, but I wouldn’t be afraid to adjust these levels.

I never set the master volume on my VCI-400 to max. Usually somewhere around 3/4. Basically I start with the master volume low and loop a loud section of a track, I start with the channel gain on the VCI-400 at 12 o’clock, and put the channel line fader at the top, then I adjust the channel gain until the channel meter just hits yellow then. Then I increase the master volume on the VCI-400 until the master meter just starts to hit yellow. Then I back it off a little. This is the level that I send to the club mixer. Basically this is the loudest, clean level that I can send. Then from there, I’ll adjust the gain on the mixer channel that I’m plugged into until it just hits the yellow too then back it off a bit. Now I have the loudest and cleanest audio signal possible going out of that mixer channel. Then I use the level fader or master volume on the mixer (depending on the setup) to adjust the actual volume that goes out to the sound system. Usually the sound guys take care of the rest. One thing you will also want to check in the Sound settings in djay is the Audio Limiter (I turn this off) and Output Headroom (I set this to None). I’m not an expert at gain staging, but this is what normally works for me. Anyway hope that helps.

Lol what’s a good deal?
I feel like the sound gets less clean the more gain is involved. And usually with my DDJ SB3 I basically don’t need it. I just put up the master. On what level is your gain on the VCI-400?

You should be fine as long as you aren’t adding gain to an initially distorted signal. I normally have the individual channel gains at 0 (12 o’clock). These get adjusted for each track that I load to compensate for different track volumes. Basically just keep your channel meters at the top of the green. Then I adjust the VCI master volume to where the master level meters are at the top of the green. Now you have a clean and load signal going to the club mixer. Easy.

I got the controller today and connected it via IPad to Djay. It seems to work, a signal goes into the channels but I don’t get an output. Not on the master nor the headphones? Any chance you could tell me what firmware you are running? Would I be fine installing the latest Serato update?

The only Vestax file I can find on my computer is “Vestax_VCI400_Driver_v161.exe” so I’m assuming this is it. I tried to attach it here, but the file extension is not allowed. Just so you know, I’m using the Ean Golden SE edition controller. I don’t think that should affect anything, but it might.

Also here’s a screen shot of my Audio Device Setup in djay. This might help you.

First of all thank you for all the input!! I really appreciate it!
That’s the audio driver for your pc, on it you can see which version you are running for the audio and on a separate driver is the MIDI firmware. Hassled my way through it today, not able to install it on a Mac, borrowing a pc and eventually upgraded to the latest Serato firmware. Now I also get a master signal :heart_eyes:

Is there a latency between your master output and your headphones or is it in sync? Did you have to midi select most of the buttons yourself? And does the deck switch function work natively for you? Mine seems to be at the front bottom not with the destined deck select (A/C) (B/D)

You’re welcome. Happy to help. Glad you were able to get the firmware sorted out!

  1. Audio Latency: I do have an issue with this, but I thought it was something specific to my setup she nice Algoriddim support wasn’t able to duplicate it. The Master audio is delayed compared to the headphone audio when using my iPad. I totally forgot to mention this because I discovered a work around that is second nature to me now. When you first load djay and connect your VCI to your iPad and before you start playing music, try turning your Bluetooth on the iPad ON then OFF again. If your Bluetooth is already ON, then you need to go OFF, ON, OFF. This gets rid of the audio delay for me every time. You have to do this every time you first start djay with the VCI connected, but the work around works for the duration of your session. I submitted a bug report to Algoriddim ages ago, but it’s never been fixed.
  2. I have heavily customized my MIDI mapping to suit my workflow and DJing style so I can’t remember what’s was pre-mapped, because I normally customize most of the defaults.
  3. Yes the Deck A/C and B/D toggle switches work natively for me.

@Emily is it possible to check on this again? This seems to be a more common issue. Could it be related to the firmware in use? Which one would Algoriddim advice to use?

@Slak_Jaw can you give me an idea how you set it up? I‘m very curious :relaxed: Is there maybe a way you can share a file or something with me? Kinda wanna know if it would work on mine :sweat_smile:

So when you use the deck switch toggle the entire half of the controller switches? Like for me in order to hit play I also need to toggle the small switch on the front and the filters at the very top are not accessible for deck C and D. It clearly seems to be an Algoriddim problem, doesn’t it?

@Fresh27 I don’t think my MIDI mapping would be of much use to you. Like I said it’s heavily customized to my unique workflow and DJing style so a lot of the buttons, knobs and encoders don’t function as labeled on the controller or as you might expect. I think it would take a lot of work for you to go through and manually figure out what each control does. Even if you did, there might still be some surprise behavior that you weren’t expecting. Instead, I encourage you to customize your own. The MIDI learn function in djay is very intuitive and easy to use. Out of curiosity, did you buy the SE VCI-400 or the regular one? The SE has blue filter knobs and the regular has red ones.

Yes, when I use the Deck Select toggle switches below the Tempo faders on the top of the controller all of the controls on the entire half of the controller switch to the selected deck. For me the small switches on the front of the controller are used for the 3 different pad modes for the 6 buttons below the jog wheels. It sounds to me like there is mismatch issue with the default MIDI mapping and perhaps your controller firmware. Again, what I suggest is coming up with a plan for how you would like all the buttons mapped and go in and MIDI map these controls to your liking. Here’s a help article that will get you started:

Really, thanks for all your help and input!! Actually I wasn’t gonna use your MIDI setup, I just wanted to see if the deck select would work the way it’s supposed to. I‘m also thinking it might be firmware related. I hope @Emily can give further input on that matter :sweat_smile::point_right::point_left:

I got my hands on a regular Vestax VCI-400. The special edition was nowhere to be seen :rofl:

No problem. I’m happy to help out.
Okay, yeah it could be a firmware issue or something to do with your VCI vs my VCI SE. I’ll send you a copy of my MIDI file in a PM. Hopefully it works for you.

Thanks, actually doesn’t work :sweat_smile: switching the decks and pressing play starts a drum looper :rofl: but I also can’t find a MIDI control setting that would enable me to configure the deck toggle manually.

Btw one thing has gotten better, the latency is gone, after I changed the adapter for my headphones. Now it’s perfect :sweat_smile:

1 Like