Pre-Cueing - djay pro - DDJ-WeGo2

I’m having trouble pre-cueing with headphones on my DDJ-WeGo2. It’s not my headphones because I tried it with the older version of djay and it worked. What should I do?

Hi Adam,

What’s your Devices setup in djay?

Pre-cueing should definitely be set to 3&4. Then click on “Apply” after changing it.
Also, make sure that the pre-cueing volume is turned up on your controller.

Main Output: DDJ-WeGo2 - Channel 1&2
Pre-Cueing: DDJ-WeGo2 - Channel 1&2

I’ve tried switching to Channel 3&4 but it still doesn’t work

Hi Warren,

I’ve tried what you suggested but it still doesn’t work for me. I’m not sure what to do! the old djay software works perfectly fine so I’m pretty sure it’s not a hardware issue.

I’m having the same problem. No audio via DDJ-WeGo2 possible, but the “old” djay software is working perfectly!

is there a solution??

mine works

mine works! thanks

mine works! thanks

Hi there,

are you setting up the controller yourself or are you accepting the midi mapping dialog?

Lukas E.

Hi Steve Mecca,

no worries about the multiple posts. 
Can you send us a screenshot of your audio rooting (Preferences -> Devices) via
Thank you in advance.

Lukas E.

Thank you my colleagues will reach out for you as fast as possible.
Lukas E.

I have the same problem still, (a year after this post went up). Has anyone been able to restore some normal pre-cue functionality with a ddj?

All my settings are correct and I get this…

Hi Lukas, thanks for the reply. I read about the midi mapping dialog and uninstalled and reinstalled so that I would see it again, but I haven’t seen it since the first time it was installed.

Sorry, that wasn’t too clear. The simple answer is, I haven’t seen a mapping dialog since the first time I installed DJay Pro. Any suggestions to bring it back to it’s initial/default state? I thought maybe a pram reset, but I don’t want to lose other preferences for other apps…

I just double checked the mapping, and it is using the native mapping for the sx2. My problem, however is not with mapping, I don’t think, because the error is an audio error… Could I just have bad hardware?

Sorry for the multiple posts… this is the last one…

When I select my DDJ as the audio device for main and cue out, the songs don’t even play unless I switch the audio device to “built-in output” and then back, but it still doesn’t operate normally. All I want is output 1-2 for main out, and output 3-4 for cue/headphone out. It’s not doing any of this. I have the latest firmware for the sx2. I’m an audio professional by trade, and this is making no sense at all.

Thanks Lukas. Sent an email last night.

Not sure if you got my email, but I sent again to Please reply. I’m on a trial of the software and so far the only thing I’ve done with it is try and get it to work…