Problems after update !

Nothing plays after update !
Running a Mac Pro with 2x2,4 Quad Core Intel Xeon.
Yosemite 10.10.5
After updating, tracks loads but does not play.
When hitting the play-symbol it goes green, the little red light on the deck goes red… and thats it … Turntable does not rotate, can’t scrub the time - line nothing … Anybody out there with a solution ? Have tried removing app and downloading a fresh one.

Works perfectly here. Best update so far.

I would uninstall it, restart your computer, than re-install it.

Find it in the finder or in the applications list and drag the icon into the trash. Empty the trash then restart your computer. After that, just go back to the app store and re-download it.

El capitan or yosemite?

I have no problems, using El capitan.

Hi there,

first of thank you guys for your help.

If the problem is persisting after the reinstall, could you give us some further informations?
Are all tracks not working?
Have you tried using another track source (Spotify, My Mac, iTunes…)?
Which format do your tracks have in generell?

Thank you in advance.

Lukas E.

Hi Jerry,

which Avid Mbox are you using? Have you checked for El Capitan drivers?

Lukas E.

From all the comments regarding problems after the latest upgrade, it seems yet “another” example of an unacceptable upgrade release by a Software vendor.

No information about the release and no Beta testing on their own.

You wonder what kind of people make these decisions? ~ i.e. as an upgrade they already have been paid for the product, so releasing it before it is ready serves no purpose ~ except perhaps to lose customers not gain them ~ bad business me thinks. !

Lee G
“Helping Artists, Healers and Conscious Business Thrive"


How do you do that ?

Yes that simple I forgot : Thank You

~ I use App Cleaner for that process ~ gets all the hidden files

I assume then e using all the features that have been commented on and are having ZERO problems ? ~ or at least nothing that a fresh install won’t solve ?

Awesome Thanks for your help !

Thanks Tucker, did all that and no improvement !

Upgraded to El Capitan and now dJay Pro works OK. Now the Mbox from AVID stopped working… typical AVID, no updates for old products, they just want you to buy new ones !

Hello Lukas, searched the InterWeb and everywhere it says that there are no drivers for El Capitan for AVID products: This is what AVID writes on their site april 18 2016:

Apple has recently released OS X 10.11 (El Capitan) as part of a free upgrade available to all Mac OS X users. Avid has not completed qualification of the new OS X 10.11 for all products and strongly recommends customers do NOT upgrade to this OS version until qualification is complete. There are open bugs and known issues with current shipping versions of some of our products that will need to be addressed prior to qualification. Please find the qualification status for each of these products below.