Recording produces different gain levels

I’m making a recording of several songs mixed together. It’s more like mashing up songs than just mixing them together so I am not recording the mix all at once. I record the first and second songs mixed together and then I stop. I then take the the second song and mix it with the third. So that produces 2 files. I then stitch this together in a DAW. I’m using Audition because I have CC and don’t have anything else.

Something I’ve noticed is the gain can be way off between two recordings. So when the I stitch them together and play it back, the loudness suddenly jumps. It’s pretty annoying and not sure how I can avoid this. I could match the gains but increasing/decreasing either of them, but its full of compromises when you have multiple tracks.

When I record with Djay, is there a way to control the gain? I am making sure that my gains are matched when I record from both decks. Equalizers I do manipulate some, but nothing drastic. I do make sure that I have the same settings as I transition.

Almost all the songs I use are wav or 320kps and I always record the mix as a wav file.

I’m not doing any preprocessing to all the mp3s to make sure their gains are matched. I’m not really sure if that matters in this case though. The same song has double the gain in one recording compared the other.

I am concluding that its the way Djay records mixes. Maybe it attenuates the gain according the peak frequencies, rather than clipping them? That might make sense because you when mix two songs together, the overlapping sounds might peak higher together than on their own? Not sure, not trained in audio engineering. Just an amateur.

So the 1st recording peaks differently than the 2nd recording and the 2 song used in both recordings is heard with 2 different gains?

Well, there’s no way to configure this if this were the case. But just curious if people know what I am even talking about and have a solution.


Do you have the audio limiter enabled? (Options > Advanced > Volume > Audio Limiter) … That seems to make the gain a bit unpredictable … If you have it enabled try switching it off.

Thank you DJ STUB you are leading Scott in the right direction. 

@Scott Eshbaugh 
Also could you check in the Advanced Audio Settings (Options > Advanced > Volume) if you activated the Auto Gain. This feature is helping you by automatically adjusting the Gain of your tracks to the ones playing.

Lukas E.

Hey y’all thanks for the tips. I will give that a try!