Search Box deactivates After First Character


Whenever I click the search box to look for title it gets deactivated after the first character it gets deactivated. Meaning that any character after that gets interpreted as a shortcut key which results in me messing up the mix.

Clicking the search box after that makes it useable then but intuitively I don’t do that while in the mix. Anybody encountering similar problems?

I am having the same issue - after 1st character is types, the hot keys are activated and it stops songs or cues or causes loops - has to be fixed please.

same problem - needs an immediate fix.

This is happening to me I’m going to try installing Sierra if I can until a fix. Also under video screen large tiles all the videos don’t show up. They are there only shows about 12, if you go to smaller tile they show up.

Sorry uninstalling sierra

Lucas, might you have an approximate ETA for an update?

This issue is driving me crazy. I CANT focus on my mix or set with this issue. It totally messes up my mood and flow.

This is in need of a serious resolve

Update on this.
I can search spotify with no problems.
When i search in my music on my hdd, this problem shows up.

Workaround: disable key shortcuts. Not the best, but…
now you only get a wanring screen, but the music keeps playing.

Happens only after the 1st character.

Hi there,

thank you for pointing this out. We had a hard time reproducing but it appears that this has to do with macOS Sierra. We are working at a fix, sorry for the inconvenience.

Lukas E.

Thank you for the video Kenneth, really appreciate it.

Lukas E.

Hi guys,

thank you all for sharing your feedback. We are working on this issue will provide a fix as soon as possible.Stay tuned for updates.

Lukas E.

Hi Danny Nutt,

be assured that we will release the next update as fast as possible. Please note that this always requires careful testing.
Sorry for the wait.

Lukas E.

I have the same problem. Please somebody fix this

I have a video of this problem, how can I send it to you

I have a video of this problem, how can I send it to you

Here is the link to the video on youtube

Hi all, I’m having the same problem since installing Mac OS Sierra. For now, if you use a midi controller, the best thing to do is to ‘disable keyboard shortcuts’ in Preferences/General. This at least stops unwanted looping or skipping ahead of a playing track which I had at a gig on Sunday! Now all you need to do is tap the search bar again and you can tap in more letters for your song search. Not a complete solution, but certainly better than before.

This really is an issue that needs to be fixed ASAP. This won’t do your image any good people of DJay. I am seriously thinking of migrating to Traktor!

Come on Djay, why haven’t you fixed this issue yet??