Songs Greyed Out In Djay App...?

Ok. Me and a friend both have the same spec ipad 3, both have downloaded a number of similar albums and both have the latest version of djay app…

Within the app when i select albums over 50% of my songs that i have paid for from the app store are greyed out and cannot be used in mixes!! I have been into apples generic music app to download any from the cloud but there is no symbol to download any of the missing songs. They all play within apples generic music app. My friend with the same setup as a couple greyed out but nowhere near the amount not available to me. I want this fixed asap as i cannot use the app i paid good money for properly or the music i paid money for.

Thanks.

2015 and I’ve got the same issue. The song wasn’t fully downloaded and now whatever meta file accompanies the song in djay2 is flagged as bad. Can’t shift it at all.

Hi,

Which iOS version do you have? Create a new playlist in the Music app containing the greyed out songs. Is there a cloud icon at the bottom of the playlist?

Hi Patrick,

You should probably know that this is not a djay issue. All songs, which are unavailable, are automatically greyed out.

Some songs, even if you can play it with the Music app, can be inaccessible for djay.

If you’re using iTunes Match or if the songs are purchased from the iTunes Store, try deleting the song in the “Music” app and then re-download it by tapping on the cloud icon.

If you’re not using iTunes Match, then please try re-syncing your songs.

You can enable “Hide Tracks in the Cloud” in the “Library” settings (tap the gear icon).

Hi Jamil,

Can you please upload a screenshot of the song’s Summary info in iTunes on your computer?

Hmm, this track should normally play fine. Which iOS version do you have? I recommend trying the following:

  1. Make sure you have the latest iOS
  2. Swipe your finger on the song and delete it from your iPad through the Music app
  3. Restart your iPad
  4. Tap the cloud icon next to the song in the Music app to re-download it
  5. Try playing it again in djay

Fix your itunes library and Djay Pro will work fine. It reads from iTunes.

If you don’t want to rely on iTunes, add your folders.

Don’t blame the software for your itunes files being messed up.

I am having the same problem…but what worked for me was that i deleted the song from my Iphone and then plugged it into itunes and manually put the song back on the iphone from my Mac it must be an iCloud bug or something…its something that should be addressed quickly i hope its not convenient to have to plug it into your laptop to get the song to work…hope this helps you

Same problem here also ver 6.1 ipad 3 album is grayed out and will not let me load a song

i’m on the latest ios 6.

I will try and create a new playlist later and see if this works.

I cant understand it…

Thanks,

i tired creating the playlist last night but still no cloud icon to download the greyed out songs. I have downloaded my albums from the itunes store on my ipad. I dont have it backed up to a laptop. It is ridiculous if i have to backup my ipad up to a laptop, delete the music and transfer it back again. I bought the device to move away from a laptop as i want to only use my laptop strictly for word processing etc…

Any ideas…?

Same problem here. It’s not very encouraging that the top of the site says that Algoriddim employees are here to help but this issue has been unresolved for a year, however…

This is only a problem for Djay. Not the Music app. Not the Traktor app. Just Djay. Very helpful reply, though.

Thing is earlier in 2013 the same tracks now greyed played just fine. Using iTunes Match, No matter how many times I delete and re download these certain tracks remain greyed out. Turning match on and off, deleting all tracks and re downloading from scratch made no difference
Has anyone figured out what it is about these tracks that stops apps from being able to read them - some sort of DRM ?
Here’s an example - Severity Zero - Metamorphosis just will not play (although earlier in 2013 it used to), yet Analysis Paralysis, the title track from the same EP plays just fine

(Both tracks I just mention play fine using the music app but Metamorphosis is greyed out in idjay 2)

Thanks for the response - here’s the image for the particular track I just mentioned that won’t play ](http://i.imgur.com/QHvQrmE.jpg[/IMG])

I hate this iCloud crap…I want to delete all my music from iCloud, what I did is turned off my iCloud from setting but when I opened my DJAY 2 the songs are still there but greyed. I want to delete all of them…

Yah this is fu$&'d!!! Where did all my music go that i had on here… I updated to 8.4. Everything is greyed out… How lame

If your iTunes songs are greyed out, please check the following 4 points and make sure all these parameters are set perfectly.
• You are disconnected with iCloud Music Library.
• The music tracks are not available for some countries or regions. If you search them in the iTunes, they will be greyed out.
• Restrictions are put into use for certain tracks.
• An album’s changes or edits are made by an artist or content provider.
If the problem is not fixed, please try this new way for Fix iTunes Songs Greyed Out Issue.