5.0 Bpm glitches!!

…as who? What are the problems?

What is “this”?

It seems to me after reading this thread, people seem to be misunderstanding how Fluid Beatgrid works.

They’re so used to DJ software incorrectly assigning a single BPM to all tracks that they see any variation as a problem. Actually it’s the other way around. Now we’re able to see the true BPM any any point. If it varies, we see it.


Correct. You hit the nail on the head.


I made an account here just to say that this update is horrible. Songs that I am positive are straight BPM, are being recognized as dynamic and the tempo is jumping all over the place. All songs should be defaulted to straight or at least the option to default them should be added. I have a gig tomorrow and this is causing me so much unneeded stress.

Even manually setting those tracks to straight is an issue because I can no longer set my beat grids properly.

1 Like

Besides the annoyance of seeing the BPM jump, what is actually going wrong?

I mean sound wise?

1 Like

WHICH SONGS? Please guys, provide some information.

When you say the “tempo is jumping”, are you just seeing the BPM readout changing? It’s supposed to!

If it’s changing, then it’s showing you the variations in tempo from the track, not just an average as most software does.

1 Like

Can you provide some tracks so we can test also.

1 Like

@DJ_Akwaaba I hear your frustration, but in order for us to assist you, can you please provide specific details about the issue you are experiencing? Thanks!

Good day to the Djay Pro 5 Team… but I must say the BPM Glitches are real…

An off and on switch for Straight vs Dynamic.
It must be a GLOBAL SWITCH, not just per song being played. I should be able to turn it off and on in settings. That should be easy enough for the engineers to resolve with a quick update while they continue to perfect this ground breaking software.

The problem I experienced is that songs would either speed up or slow down drastically in bpm. Even the best drummers in the world will speed up and slow down but not so much that it captures the attention of the listener. Djay Pro 5 is speeding up and slowing down and it’s very noticeable… If you’re on the dance floor, you’ll know…

Implement the GLOBAL SWITCH for now for Straight vs Dynamic and this will keep everyone happy while this problem is being worked out.


1 Like

Thanks for sharing your thoughts @Alski. Can you please also provide some specific song IDs where you’ve experienced this issue? This will really help to communicate the issue with the engineering team. Thanks!

Exactly! It’s no use just saying “songs did this” - which songs? Artist and title?

What BPM should they be? How much did they change? What tracks were you mixing together (give artist/title/BPM of each)?

I still think people are misunderstanding the new system, and seeing the variation in the BPM readout as a fault.

Hopefully @Alski will be able to provide the tracks that were causing issues. I’ve seen these posts a few times though when folk have posted issues and then not followed up with track info.

I tried to come up with some reproducible examples, maybe this can help the dev team:

  • Load “DBC1” by Luke Vibert on the left deck (160bpm)
  • Load “Dub Plate Circles” by Undercover Agents on the right deck
  • Both streamed via Tidal

In version 4, Dub Plate Circles was correctly recognized to be around 165 bpm, which was automatically halfed to 82.5bpm.

(Sidenote: version 5 doesn’t half the bpm of my jungle/dnb tracks automatically anymore for some reason. This affects how the touch effects and loops work. Really confused me at first until I realized what’s going on. I then had to go through all my tracks and half the bpm manually again, for my effects and loops to work as expected.)

In version 5, the dynamic mode thinks that the track varies between 76.8 and 111.4 bpm.

At the very beginning of the track, it says the track is at 110.4 bpm.

When I activate sync (while DPC1 is loaded on the left), it speeds up the track to 160bpm, which makes it 45% faster than it should be.

At first I thought I can get around this by skipping to a part of the track where the track is shown to be at around 80 bpm, activate sync there and then jump to the beginning again.

But shortly after I hit play, the sync is deactivated and the bpm is reset to 110. But it keeps saying it’s only 3% slower than the original and the timing is correct in this case.

Unless I notice that sync is off and enable it again, which speeds it up by 45% again and ruins the mix without any hope of quickly fixing it manually afterwards.

This is increbibly confusing and impractical :confused: And I don’t see the benefit of this new behavior.

At least the straight mode fixes the issue for this track and just sets it to a fixed bpm of 165.

But unfortunately that cannot be said about all tracks. For example, “Beats for now” by Subjects was previously correctly regognized as 80bpm. But version 5 claims that it’s between 105 and 107 bpm in dynamic mode, and 106.7 bpm in straight mode. This bascially means I cannot use the sync feature with this track anymore and have to beatmatch (or overwrite the bpm manually).

As a developer myself, I understand how heartbreaking feedback like this is for a new feature, that you feel is revolutionary and that you probably put a lot of effort and smart thoughts into.
But as a user of your software, this update causes a lot of frustration and wasted a lot of my time already, trying to work around these quirks and getting my mixes to work again.

Please consider adding the ability to make straight mode the default. Also halfing the bpm by default again would be nice.
Or even bring back the old bpm/grid/sync logic. From my perspective it was pretty much perfect and I see no reason to change it.


Thanks for the additional information @deje1011. I have forwarded this to the engineering team to see if they can reproduce this and offer some feedback. I’ll report back when I have more information.

Thanks :slight_smile:

Another example, this time illustrating the sync/timing glitch:

  • “Lotus” by Zero Gravity on the left
  • “Revelation” by Metamorphosis on the right
  • Streamed via Tidal

Go to the first beats of both tracks, activate sync and start both tracks at the same time.
In dynamic mode, sync is deactivated shortly after starting the tracks and they drift apart quickly.

In straight mode, it works fine. The two tracks stay in sync the whole time. The only thing to note here is that you have to slightly adjust where to start “Lotus” in straight mode because the first note isn’t directly on the first beat anymore for some reason but a tiny bit later.

The problem there is that halving (not halfing) is just your personal preference. It’s not the actual BPM.

I just had a listen to Beats For Now. I’d say that’s 160 BPM not 80. It’s not a slow track.

Same with Jungle / Drum & Bass. It’s uptempo stuff, so IMO the BPM should not be halved “automatically”.

Hi PK,

Thanks for the response but I think you’re missing my point.
Yes, 160 is the correct bpm and the halved bpm is just my personal preference. But the reason that I developed this preference is that the previous version did this by default and so I got used to the effects and loops being relative to this tempo.

So it was irritating to me that my effects and loops where twice as fast in the new version. But since there is an option to adjust that manually, I can live with that. I just would like to add that changes like this should have a good reason, since it requires users that relied on the old behavior to understand what caused the change and how to restore the old behavior (and in this case also going through all tracks and manually adjusting them). It would have been nice to keep the halved bpm for existing tracks and only use the new default for tracks that weren’t in the library before.

Please focus on the other issues though, the halved bpm is not that important.

For me, Beats for Now is shown as having a BPM of around 106, which is definitely wrong:

And even that isn’t a huge problem, I can manually fix the BPM for this track. The main issue is the dynamic option behaving in unexpected ways and it being the default. And that you retroactively changed this for existing sets, which your users put many hours of work into.

Also halfing the bpm by default again would be nice.

Hey @deje1011, you can set a preferred BPM range for the analysis that is meant to address this very issue, particularly with genres where the BPM can be ambiguous with regard to half/double time. Just go to Settings → Library and choose your preferred range under BPM. This seems to also indirectly fix the track “Beats for Now”.

Thanks for sharing these examples and for the suggestions! Sorry you’re facing issues with Fluid Beatgrid. Unfortunately, the new system can make mistakes, but we’re working on identifying and improving them from feedback like yours. Feel free to reach out with any more issues or suggestions.


Nope, no option. It’s honestly insane that they’d ask us to manually click straight for every single track we load. I only need dynamic BPM when doing vocal mashups or something like that, which is rarely, and I see it glitch a ton when I’m just mixing normally. I opened a suggestion for it, but looks like it’s closed now

Ideally, we’d expect the system to automatically detect and set that for you. Some tracks lie close to the threshold of being considered “dynamic” (think old school HipHop, etc.) and the system prefers that, but those grids should be near identical to the straight one, if the underlying track is actually straight.

We’ve addressed the issue of sync bending tracks to cope with dynamic grids in the latest update which might considerably improve the experience with fluid beat grids, so feel free to try that out and get back to me. In the meantime I’ll reopen your suggestion and address the issues raised in the original post there.


Hello everyone, I’m happy to report that the BPM fluctuations with certain songs has been improved in the latest djay Pro 5.1.1 release.

1 Like