Actions missing in MIDI learn (e.g. play/pause) - Djay Pro for Windows


I’ve recently purchased Djay Pro for Windows and am now trying to configure my MIDI controller. The controller is recognized by Djay Pro and I have already succesfully mapped several functions onto the controller. However, I have the impression that some Action buttons are missing from the drop-down menu.

For instance, when I read the “Configuring a MIDI controller using MIDI Learn” tutorial, for a given button it suggests choosing Deck 1 as Target and Play/Pause as Action. My installation lets me select Deck 1 as Target, but Play/Pause does not appear in the Action list. In fact, many functions that I would normally expect there are not shown–the list starts with Jog Wheels. Things like Jump to start etc. are not shown.

In addition, the Advanced Settings screen does not appear to work either. Sometimes it lets me set the type of button I chose (button, knob etc) but at any time all options remain gray and inactive.

Does anyone know how I can solve this problem? I’d like to map controls like Play/Pause on my MIDI controller and the steps suggested by the tutorial appear not to be working.

Many thanks in advance!

That part can be confusing as certain assignments are only possible depending whether the controller is a fader/knob, button, or rotary controller. Switch it to another type and you’ll see the other/more options pop up.

Hi Louis, thanks a lot. I was able to figure it out eventually!

I do have another question: Djay Pro sometimes seems to “confuse” two buttons on my MIDI controller. So, I might configure everything correctly and have it working properly, but sometimes when I start the program again it does not recognize the controls anymore, or improperly links the Low EQ knob to Deck 1 Line Volume.

Is this a problem that others also have with third-party controllers? If so, is it a bug and a matter of just restarting the program? It’s also possible that it’s specific to my MIDI controller, which is a little old.

Thanks again :slight_smile: