Apple Music on iPad unable to sign in

I recently downloaded the app for the free trial. It works fine on my I phone with Apple Music but when I use the I pad get an error when trying to sign in to Apple Music. It says “ your session has timed out. Sign in again” we have family sharing and Apple Music works fine on various devices .

Hi @AndyL,

  1. Please delete the djay app from your iPad,
  2. Log out of the Apple Music App on your iPad,
  3. Perform a Forced Restart (Force restart iPad - Apple Support),
  4. Make sure you are logged into your iPad using the same Apple ID that you used to log into your iPhone,
  5. Download and install the djay Pro app on your iPad then try logging into Apple Music again from within the djay app only.

Thanks - I have tried that and still the same error

You’re welcome @AndyL

  1. Are you running the same version of djay Pro on your iPhone and iPad (5.1.1)?
  2. Please try logging out of Apple Music on all of your other devices then logging in on the iPad only.

Sorry that didn’t work either . Logged out of all Apple Music on all other devices . Have reloaded app on my phone and it still works

Okay @AndyL. Can you please confirm if the standalone Apple Music app on your iPad works and you can log into it? I just want to confirm that the issue is isolated to Apple Music within djay Pro.

Other than this, I can’t think of anything else to try. I have forwarded this to the engineering team to see if they have any other suggestions. In the meantime, can you please share more details about your setup:

  1. iPad model details
  2. iPad OS version

Thanks!

Hi , Apple Music is working as normal on the iPad . It’s an iPad Air 9th generation and is using IOS 17.3.1. Thanks again

Thanks for the additional information @AndyL

Hi @AndyL,

Can you please confirm if you are trying to log in with a kids account on the iPad, or with the same account that is successfully working on the iPhone? Thanks.

It’s the same account on the phone and the iPad
Thanks
Andy Lindsay

Thanks @AndyL,

  1. Are there any network connection differences between your iPhone and iPad? Perhaps a VPN running on one, but not the other? Or one connecting to WiFi and the other connecting the cellular network?
  2. Can you please also share a screenshot of the error message?

Hi @AndyL, I’m following up on my post from 10 days ago. If you are still having issues, can you please respond to my post above? If I don’t hear back in a few days, I will consider this solved and close the topic. Thanks!