Apple Music Streaming Songs Not Loading

When I try to load up Apple Music streaming songs from “Music” within djay I see the song try to load it then fails. It can work its way right through a playlist doing this. I have closed down and restarted both djay & the Apple Music app. Other times it works perfectly but there doesn’t seem to be any rhyme or reason as to when it will and won’t work. It happens on both my iPhone 14 Pro and my 4th 12.9” iPad Pro both running iOS 17.3.1 and djay 5.1.1. Am I doing something wrong, is it a bug or a constraint that I’m not understanding?

2 Likes

Hi @Leigh_Brown,

  1. How’s your internet connection?
  2. Are you using a VPN or other network proxy restrictions?
  3. All I can think of to try is logging out of Apple Music from within djay and the Apple Music app on both devices. Then perform a Forced Restart of both devices. Launch djay, log back into Apple Music within djay and try again.

Internet connection is at home while I’m trying this with no VPN. The sign out fixed helped but it has started reoccurring in both v5.1.1 and still in v5.1.2. It only happens with Apple Music streaming

1 Like

Hi @Leigh_Brown,

Are you able to reproduce this issue easily, and if so, would it be possible for you to provide us with a video of this issue in action?

Looking forward to hearing back from you!

1 Like

How do I get a video to you?

@Leigh_Brown, please upload your video to your Dropbox/Google Drive, enable the necessary sharing permissions, then share a link to the video here.

Link is here. Although in the video I didn’t restart the device, when I do restart the device, the same thing happens. It’s really random in that sometimes it works, other times it doesn’t and there is no rhyme or reason as to when it will and won’t work:

1 Like

Hi @Leigh_Brown, please enable sharing permissions on this file so we can access it.

I’ve updated the permissions, here’s the link:

1 Like

Thanks for the video @Leigh_Brown. That’s very helpful.
Are the same Apple Music streaming playlists and songs loading and playing fine from within the Apple Music App?

1 Like

Yes, all working fine in the Apple Music app

Okay, thanks for the additional info. I can’t reproduce this on my setup, so I’ve forwarded it to the engineering team to see if they can reproduce it and offer any suggestions. I’ll report back when I have news. Thanks!

Hi @Leigh_Brown, I spoke with the engineering team and they have a couple of follow up questions:

  1. Were you playing Apple Music tracks on another device during or right before trying this?
  2. When this happens, are you able to load the same tracks manually on a deck (i.e. not using Automix)?

Thanks!

  1. No Other device was using Apple Music at the time

  2. I was not able to load tracks manually

Thanks for the quick response @Leigh_Brown. I have forwarded them to the engineering team. I’ll report back when I have news.

Hi again @Leigh_Brown, the engineering team has a follow-up question:

  1. What happens when you try to manually load one of those songs from those same playlists to a deck without using Automix? If you get any error messages, please screenshot them and share here.

Thanks!

Hi again @Leigh_Brown, just following up on my post from 9 days ago. Are you still having this issue?