Audio device not recognized in djay

I am having issues with djay 4.2 on my Mac that I had not experienced with previous versions (nor do I seem to be experiencing on the latest iPad version).

I can see my iTunes Playlists and the individual Songs within the Playlists. I can drag a Song to the Turntable and the Waveform, BPM and Album Artwork load just fine.

When I press Play (using a Mouse or my Midi Controller) the Platter spins (slowly which is not normal), however:

  1. The Song does not play (no audio, nothing).
  2. The cursor above the Waveform does not advance.
  3. The Needle Arm does not advance.

I cannot click on the Waveform to advance the Cursor, however I can drag the Needle Arm and the Time will advance but the Song still does not play nor does the Cursor on the Waveform advance. Even stranger, when I advance the Needle Arm to say 5:30 on a Song and then try and load up a different Song the Needle Arm stays at 5:30 and does not reset.

I’ve tried loading new Songs, old Songs, new Playlists, old Playlists. Nothing seems to work. Nothing is playing yet the Platter keeps on spinning when I hit play.

I will add (for troubleshooting reasons) that my Music is not purchased through iTunes. These are mostly original tracks and tracks purchased through other sites like Beatport. They do not have DRM protection enabled, and use to work in djay just fine until the recent update. I both import them into iTunes, and work with files outside of the iTunes directory by simply dragging them into a Playlist. I have not changed anything in terms of folder/file structure since the last update and everything worked just fine before.

If this problem cannot be fixed, please let me know how I could perhaps revert to an older version or get a refund for broken/unusable software.

If you need/want any additional information, please feel free to ask. I am more than happy to help troubleshoot this problem so I could use the product.

Hi Kris,

Thanks for contacting us.

Are you using any external audio devices with djay?

As an experiment, please try quitting and restarting the app.

If your audio device is not working with the App Store version of djay, please download the demo version and see if it works. If yes, then this means that the driver for your audio interface is not compatible with sandboxed applications such as djay. Please contact the support for your device and check whether they have a new driver which is compatible with sandboxing.
In the meantime, you can email us at support@algoriddim.com to ask for a complimentary license for the non-App Store version of djay 4. Please make sure to attach a copy of the purchase receipt for djay for Mac.

Hi Brian, which audio interface do you have?

I am using a Digi 003 Rack. I’ve tried restarting the app, the Digi 003, and my computer with no luck so far. Still the same problem.

I am using a Digi 003 Rack. I’ve tried restarting the app, the Digi 003, and my computer with no luck so far. Still the same problem.

So I downloaded version 3.0 from the website and the tracks loaded just fine. As I said before the problem seems to be with version 4.2.

Please help!

Under System Requirements (in small print) you’ll find the link on this page: http://www.algoriddim.com/djay-mac/do…

UPDATE: July 14, 2013

I decided to give 4.2 one more try and I have discovered that it is my external audio box (Digidesign 003) that is not working with djay.

When I set the Audio Output to Internal Speakers my tracks play. As soon as I set the Audio Output back to my Digi 003 I get the original problem I posted in this thread.

Older versions of djay play well with my Digi 003 but apparently the changes made in version 4.2 cause problems.

Is there a planned update? This is a problem for me, not being able to use my external audio box instead of internal mac speakers.

Using the Digi 003 allows me the ability to setup Main speakers, Monitors, Headphones, Midi Controller, etc.

Using the internal setting means I get to listen to really bad speakers with no Headphone/Monitoring options.

I also have this exact same problem. I’ve heard that this just started happening on the newest version of Djay (4.2). Is there any place that I can download an older version. It would be helpful because this preventing me from using Djay currently.

Can you give me the link to download version 3.0? I couldn’t find it on the site.