Auto crossfade button causes volume slider to jump to maximum volume.


After I updated DJ Pro AI, I click the cross fader triangle toggle button. As soon as I click either the left triangle or right triangle button that starts the automatic cross fading, the slider volume to jumps to max volume. This never happened when doing the same thing with the previous version of the software. I’m running version 4.0.9 on a MacBook with the M1 chip on Monterey. This means I can’t play my tracks at a gig and leave my DJ controller unintended while I get food, etc. I did this at home and I had the volume slider mid way up. Autoplay played the next track at maximum volume running the risk of blowing my speakers.

I checked to see if any new preferences control the sliders when the triangle auto crossfade buttons are clicked and didn’t find any related preference. Looks like an introduced bug or a new preference I’m not aware of. My gig is tomorrow and I really need this running properly.

This video shows what happens: Slider jumping to maximum level

Thanks in advance.


I’m getting the same thing happening on Automix, every time the song fades from one deck to the next, the volume jumps to 100% even if the next deck’s volume slider on my controller is at zero.

In settings/sounds, what is the Crossfader set to?

I have some bad and some good news about this bug. I’m using a Pioneer DJ DDJ-SR2 controller and discovered that DJ Pro AI doesn’t alter the master volume knob on my controller. The bad news is I had to learn a new way of using my controller. The goods news is that I can leave the master volume knob at a level that’s good for the party guests and that allows me to use AutoMix and walk away from the controller when needed and not worry about blowing my speakers. For example: I had a gig today and I set the master volume know at mid way and set my 2 channel volume sliders all the way up. I started AutoMix and it started to play a track. When the next track was cross faded in, there was no surprise volume increase. :smiley:

I sure hope they fix the bug and don’t add any coding that will mess with the master volume.

As far as what to do with my mics, they aren’t going through the controller. I run them through a mixer so I can control the output for each mic to go the speakers.