Automix - help please

I’m playing a DJ gig with the following time flow:

Hour 1: Background music that I’ll play as a shuffled playlist with the Automix feature.

Hour 2: DJ set.

Hour 3: Background music using that same background playlist using Automix again.

Here’s my query: When I go to Hour 3 and play that shuffled playlist on Automix, the djay app plays some of the same songs as in Hour 1. In other words, the app shows a “check” next to the song (registered as already played) but is including already-played songs. How can I correct this?

Thanks!
Neil

There is an option in the library settings for remove song when played. That way, it won’t play the song again. I think you will need to make sure that it is one session, maybe have a practice before your event.

Thank you. When I click that option to remove song when played, it doesn’t
seem to work. The song still shows in my playlist with a red check. This is
different than the Automix issue I wrote about earlier. In other words, the
red check is there as is the song after it plays regardless if I’m DJing or
if it’s on Automix. Any suggestions? Thanks again! Neil

Also, when I tried to option to remove song when played during automix,
then DJ, and then come BACK to automix after DJing, it’s still just
repeating all the same songs. Neil

On Sun, Apr 17, 2022 at 10:28 AM Neil Sachs sachsneil@gmail.com wrote:

Hi @neilsachs,

It looks as though Automix is treating your “Hour 3” session as a separate session compared to “Hour 1” which is why the same songs are being played again assuming that you have the Shuffle and Repeat functions enabled (I will provide a screenshot below for you to reference).

If you would like your previously played tracks to not play again in these playlists you need to make sure that the Repeat function is off and if that the Shuffle function is on (if you’d like those tracks shuffled that is).

Additionally, I wanted to point out that there is a setting to “Remove Songs When Played” in the Queue section of your library if you ever find yourself wanting to play back tracks via that method (I will also attach a screenshot below for you to reference). Please note that this setting only applies to the Queue and not Automix.

Have a good weekend!

This is all great info and thank you. However, the problem still exists.
Even when shuffle is on, repeat is off and the remove songs when played
(from the queue) is set to on. I think it’s a bug. Do you think it can be
fixed? Neil

Hi @neilsachs,

After speaking about this with the support and dev teams in greater detail I can say that this is expected behavior from djay/Automix.

I have made note of your suggestion and have passed this along as a feature request for our dev team to further consider in a future update.

Thank you so much!

Thanks much, Nathaniel. Yeah, good to know it’s not a bug. But it’d be
great to have the option to somehow NOT play songs in Automix within the
same overall session that have already been played. Looking forward to that
option with the next upgrade. How can I know in the next few months if that
feature is included in the next upgrade? Thanks much! Neil

Hi @neilsachs,

Check back on this thread or on our release notes page for djay found at the link below!