Automix Neural Mix transition type keeps going back to Automatic

NOTE: Please use the search function above before posting to avoid creating duplicate topics.

  • Device model (e.g. 2020 iPad Air 4th Gen): iPhone 14 Pro / M1 Macbook Pro
  • Version of operating system (e.g. macOS 14.4.1): iOS 17.4.1 / macOS Sonoma 14.4.1
  • Version of djay (e.g. 5.1.2): 5.1.6 / 5.1.5
  • Hardware/controllers used (e.g. Reloop Mixon 8 Pro): None

Summary of the issue:

If you use the Automix feature and set the Transition type to ‘Neural Mix’, it will only work for one song and revert to ‘automatic’ when you move on to the next song. The other transition types like ‘dissolve’ and etc. are fine, but only neural mix has this issue, what could be the cause? I’m using with Apple music source, and it’s happening on both iPhone and Mac.

How to reproduce the issue:


Hi @Yongseok_Park, can you please confirm if you also have Crossfader FX enabled or not?

@Slak_Jaw Crossfader FX wasn’t enabled. But the issue seems to happen regardless of whether it is enabled or not.

Thanks for the additional info @Yongseok_Park. Can you please capture a video of this, upload it to your Google Drive/Dropbox, enable sharing permissions, then share a link to the video here? Then I can forward this to the engineering team to see if they can replicate the issue. Thanks!

Here is the video from iOS version.

You can see that I set it to Neural mix before I start, and it reverts back to ‘automatic’ right after I select a playlist.
Even though I change it to Neural mix again, you can find that it reverts to automatic itself after a transition to the next song is completed.

Hi @Yongseok_Park, thanks for the video. That clarifies things a lot. Please note the Neural Mix is currently not supported with Apple Music Streaming so this is likely the reason that it keeps switching on you. Neural Mix is currently only supported with Local Music and TIDAL with the DJ Extension subscription.

Oh, Ok then. I hope it supports Apple Music soon as it obviously works perfectly when it is enabled… leaving aside that I have to force it for every single transition :sweat_smile: Thanks for your help.

1 Like

You’re welcome @Yongseok_Park

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.