beatpad input settings


I have a beatpad in combination with djay pro (latest version)
Normally when I start djay pro and then activate my beatpad a popup comes for the input/output settings.
I accidentally checked don’t show this dialog and pushed the button with my beatpad not selected.
So if I want to play right now I always have to go to settings and manually add my beatpad.

Is there a way to set my settings in a default (beatpad) state or reopen the dialog box so I can set in right?

Question 2
I don’t us the sync button, but the pitch.
I noticed that when pitching you have to go up and down to activate the pitch. Can i turn it off somewhere?


Question 1: Please try deleting your Preferences. You can get a full description on how to do this here:

Question 2: Please open the Midi configure Window, trigger the Pitch Control at your controller, select “Show Advanced Control Options” and un-check the “Pickup Mode”. 

I’m sorry, Sanny, but you have to check if the suggested device settings are alright. There’s no way of making the software detecting always the correct setting.

Awesome, Thnx for your quick and structured reply!

Hi Adrian,

I removed the file and after a restart I saw the dialog box. I did my setting right this time, but in 80% of the cases I still have to change the settings to beatpad manually.

Until now I can’t say in which case the software does it right. But I don’t do a restart very often.

Do I have to close down in a sertain way?
I normally power off my beatpad and close my laptop screen so djay pro is still active but my macbook goes to sleep mode.


Hi Adrian,

Can you give me an update on this?