Bypass Master Volume level for Recording Your Mix

Hey Everyone,
I know that questions about recording one’s DJ mix have been asked a thousand times.
But I couldn’t find anything about this particular situation?

I’m looking to bypass the master output or volume level on my hardware controller when creating a live mix?

Occasionally, I have to adjust the master level at some point during the night. This affects the volume of the mix I’m recording. Thus my question to see if there’s a way to record sets like it’s possible in Rekordbox (where the master volume doesn’t affect the recorded volume as it’s controlled by a separate virtual button)?

  • Device model: MacBook Pro (Apple Silicon)
  • Version of operating system: 13.6.3 (Ventura)
  • Version of djay: 5.1
  • Hardware/controllers used: DDJ-1000

Thanks!
Antonio

Original DDJ-1000 or SRT version?

The original should be set up for internal mixing, with master and headphone going to the unit, and a recording signal coming back. The master volume is a hardware control so should not affect the recording signal (assuming you’re recording in DJay software).

What is your DJay audio config?

The SRT version should use external mixing, but it also has a dedicated record signal and hardware volume control.

How are you recording the mix? The master volume shouldn’t affect recording unless you’re recording directly from the master output.

1 Like

Hi @djantona, djay’s recording volume is currently tied to the master volume. @PKtheDJ offered some great suggestions which will hopefully work in your situation. In the meantime, I have changed this topic from a question to a suggestion and forwarded this to the dev team for consideration. Thanks for the input!

1 Like

It’s far from ideal to source the record signal from after the master volume.

In the DDJ-1000 case though, as the setup should involve a USB record signal coming back into DJay from the hardware, the master volume on the controller should not affect the record level.

Iif it does, then IMO it’s the DJay config that’s incorrect. That shouldn’t happen.

Thanks for your help. I can confirm that the master volume on my DDJ-1000 does control the recording volume. I see no way in Settings to change this?

Thanks for your fast reply, Slak_Jaw!

1 Like

Hey PKtheDJ,
I appreciate these tips :slight_smile:

Please find below my settings:

I would suggest taking a look at the MIDI mapping to see if the master volume is mapped, then unmap it.

1 Like

Unfortunately, I’m not seeing any mapping for the Master Volume.
I think this issue could to be addressed by the dev’s in a future update.