“cannot add to playlist” error

I don’t use tidal, never have. I am logged into Beatsource. I can add to ‘beatsource’ playlists, no prob. I also have some ‘djay’ playlists, that I have Beatsource tracks added to. Sometimes, I go to add a Beatsource track to a ‘djay’ playlist, and I get an error:
**Cannot add to playlist **
Tracks from TIDAL cannot be mixed with content from other streaming services.

If I restart djay, it will then work (allow me to add that track) without the error. A few songs later, I get the error again when trying to add any track to that playlist.

There are not any Tidal tracks anywhere…I’ve never used/subscribed to Tidal.

Thanks for any suggestions.

1 Like

Hi @tsrail,

We appreciate you sharing your latest experience with djay.

So that I can better assist you, could you please answer the following questions:

  1. What model iOS device are you experiencing this issue on?
  2. What iOS version is running on your device?
  3. What version of djay are you using?
  4. Is this issue easily reproducible, and if so, would you be able to share a video recording of said issue?

Looking forward to hearing back from you. Have a nice day!

1 Like

iPad Pro, 5th gen. Djay 5.1. iOS 17.2

I see another in the forums mention that a playlist track magically switched from one source, to Tidal.

Upon further review, THAT happened here as well. I’ve never used or subscribed to Tidal. A song (Hand Clap) curiously switched from Beatsource (as all my tracks are) to Tidal (the little icon in the playlist changed to the “T”).

So I deleted it from the playlist. Then added the song back from Beatsource. And it SWITCHED to tidal again!

I will try to record the bug when I have a moment.

1 Like

Hi @tsrail,

I wanted to see if you were able to reproduce this unexpected behavior so that we can send it along to our engineering team for further review?

Happily awaiting your reply. Have a good day!


I am having the same issue. However I am subscribed to Tidal and soundcloud. I have tried logging out of Tidal, but I get the same issue.

When trying to make a djay playlist with soundcloud tracks they load as tidal instead and then when trying to add another soundcloud track i get the error “tracks from tidal cannot be mixed with content from other streaming services.”

I have been getting this error for at least a month now. At least since the whole tidal stems debacle.

iPad 6th generation, OS 16.6.1, djay 5.1

1 Like

just tried creating a djay playlist using only tidal tracks and now i’m getting the same error because tracks are loading as soundcloud tracks and when i try to add more tidal tracks i get the error again.

1 Like

Hi there I have the same issues. I use different streaming services and tracks from different sources and I see a lot of examples where sources are just randomly changed. Combined with a silly limitations from tidal to not have tracks from other sources, it makes the whole library management useless, if you have any streaming service in use. This bug exists since 3 months now and to me it is not acceptable at all. Eighter you fix it asap or just remove this stupid limitation, but you can’t consider yourself a serious dj software and let it happen for such a long period of time. Really annoying