Cannot choose 'Split Output' on Pre-Cueing (djay Pro for Windows 10)

Hi, I have a problem with splitting the output on djay pro for windows 10.

I select ‘Split Output’ on Pre-Cueing setting and hit ‘Apply’, but the sound doesn’t come out through the headphone and when I go back to setting section, Pre-Cueing device goes back to the default ‘none’. 

Anyone suffers the same problem ? 

p.s. splitter cable worked fine before on the djay app on my phone, so I believe I’m using the correct cable 

Hi Kie, We are sorry to hear that. Could you tell us which Splitter cable you are using exactly?

I had a similar issue last week but resolved by enabling the exclusive setting on the same screen. Also, I think you can ignore that the split output setting seems to be lost when you go back to the settings screen. If it’s the same as for me then it will show None but with Apply enabled. If you set back to Split then Apply is disabled which suggests that it has retained the setting - it’s just not displaying it correctly. More importantly the cue/mix slider should still be shown which also confirms it is still enabled.

If you still have issues actually getting any sound out of headphones then try adjusting audio settings on pc. I updated the default audio setting for the application in windows and this seemed to help as well.

Hi Lukas, thank you for your reply. It says “Hi-Fi OFC cable 120PF” on the splitter cable. It came with Numark iDJ LIVE 2 a few years ago. 

Hi Jon,

Thank you for your advise. I have tried again following your advise, but it didn’t work, so I bought another splitter cable (by TRAKTOR) then it finally worked ! As you said, the setting doesn’t seem to be showing correctly but looks like it switches on/off everytime I press. I didn’t realise until you told me so would have been stuck there forever so thank you! The software is not very stable and crushes time to time, but I am very happy I can finally play !