Cannot import any video into latest Djay Pro for iPad

I just installed Djay Pro for iPad Pro to do some Vjay work. However, I can’t get the most basic things to work. How can I import my own videos? Whenever I try and import a video from my camera roll, I get a message saying this:

“Could not load track. The operation couldn’t be completed. (OSStatus error 2003334207.)”


I’m having the same problem. To add to this, I had the VJay for iPad app first. Videos work fine there, but won’t load into the DJay Pro iPad app!!!

Hey there,

we are sorry to hear that.
Which iOS version are you working with?

Hi guys,

I am very sorry to hear that.

It would be great if you can send us a video of the explained issue, also showing where the video is stored and in which format via

Thank you in advance.

I don’t understand, how is one even supposed to add custom videos to Djay Pro? I can’t find any documentation about this, and the most obvious things, such as dragging from or importing from camera roll, don’t even work. So what are you supposed to do? It’s really confusing, and not in a good way.

I am using the latest version of iOS, 11.1, on the latest iPad with the latest Djay Pro version. Everything new and updated. I am using native videos that work natively on the iPad. My setup is completely standard. I tried on several iPads, with the same issue. I can’t import videos AT ALL.

I wanted to chime in since I have been having similar problems, but think I must just be doing something wrong. I just used Document to download a video from YouTube. I can see it in my photo app, and can watch the video fine, but I cannot see it through Djay Pro. I assume this is a format thing? But it is saved as a MP4, so I’m not sure exactly what I need to do to conver it. Any tips?


Having same issue. I raised this a few months ago - still no response! Seems to be issue with media being on iCloud??

Me too. Just try it yourself!

Hi Lukas. I already did do that multiple times. Like I wrote, I am using native standard HD h264 video. No videos work AT ALL. It should be simple to test. Import any video into Djay Pro and it fails. Every time.

I’ve raised this issue with you via email many, many, many times via email. You keep talking past me and can’t even acknowledge that it doesn’t work. Loading videos in Djay Pro for iPad Pro doesn’t work. At all. For any video.

Maybe you are trying to be helpful, but it’s so frustrating that you keep being baffled. You are not addressing the issue. Instead, it’d be better if you just said “Yes we can see and test this issue. Indeed videos don’t work. We will fix this bug ASAP”. But instead you are circling around the issue for months and months and never even admit this problem exists.