Can't load FLAC songs on External Drive (M2 Mac)

I am about to suscribe to djay pro but i wanted to try first. My Flac files are not loading at any deck, i am using the lastest version IOS and Djay pro as well on a mac m2 but it gets me an error, so i cannot suscribe whit this error many of my files are in Flac and do not want to change it to mp3 or other format

I have no problem with .flac (macOS) or .wav No need to change formats.

Hi @JONATHAN_MG, when creating new topics, please do not forget to answer the questions in our template with specific details about your setup not just “iPad” or “Latest Version”. This helps all of our community moderators to provide the most effective support to users with the utmost efficiency. Thanks!

Device Model (ex. 2020 iPad Air 4th Gen):
Version of operating system (ex. iOS 17.3.1):
Version of djay (ex. 5.1.3):
Hardware/controllers used (ex. Reloop Ready):

  1. Please note that flac files are supported by djay. Can you please share screenshots of the error messages you are receiving?
  2. Are these flac files stored locally on your devices or on an external drive?
  3. Can you please upload one or two of the affected files to your Google Drive/Dropbox, enable sharing permissions, then share a link to the file(s) here? Thanks!

Yeah sorry,

I am using Mac M2 2022
OS: Sonoma 14.4.1 (23E224)
Djay Pro: 5.1.6
Hardware: ddj 400-s

The Files are in my External drive SSD Sandisk 1TB

So these two files for example are not loading but is with all .flac files, aac,mp3 ,wav, aiff are good

https://drive.google.com/drive/folders/15fB7kGjdTiJdyEx9IYPEZ2_LFkAEfmCD?usp=drive_link

Hi @JONATHAN_MG, we just released djay 5.1.7. Can you please update and test to see if this solves you FLAC file issue? Thanks.

I Already update Djay Pro to 5.1.7 and still show me the error. I update after to Sonoma 14.5 and still the same. I do not think are the files cause they work with other software. I really love djay pro but cannot suscribe because of this

Thanks for the update @JONATHAN_MG. Sorry that didn’t solve your issue. Do the FLAC files work if they are stored on your internal drive? I want to make sure I have all the pertinent information before I escalate this to the engineering team. Thanks!

Thank you for the reply, I already move some FLAC albums to internal drive and still the same :frowning: and also uninstall and reinstall djay pro but nothing works.

You’re welcome. Okay thanks for confirming. I can’t think of anything else to try at the moment. I’m going to forward everything to the engineering team to see if they can replicate the issue and offer any suggestions. I’ll report back when I have news.

Hi @JONATHAN_MG,

The engineering team has reviewed the FLAC files you shared. This seems to be a specific error with these files, as we can play other FLAC files fine in 5.1.7.

They do play fine for e.g. in QuickTime Player, but not with CoreAudio directly (using AU Lab). Our guess is they are corrupt in some way. Can you please confirm if these files from the same source / encoder? Thanks!

Hey @Slak_Jaw Thank you very much for all your asistance. I already found the problem with my files and is the tag format for metadata. I used a program to edit metadata from my files and the tag format originally was vorbis but i changed it to (Vorbis, ID3v2.4.0, ID3v1) so i returned it to vorbis only and already load the .flac files. I am ready to suscribe now cause change the tag format is so easy and fast that change the files to mp3.

Thank you very much again

You’re welcome @JONATHAN_MG. Glad we were able to sort it out.