Can't load local DRM-free Songs

I purchaced djay 2 for iPad (iOS7 beta 4). I have iTunes Match, but most songs I purchaced in iTunes Plus I can’t load into djay 2. The songs are local on the iPad downloaded from iCloud. What’s the problem? THX, Uwe.

This seems to be a system bug in iOS 7 related to downloading songs. We hope it will be fixed with the golden master. Please note that djay is only supported on the latest official iOS release. 

This issue should be fixed in the latest iOS 7 beta. Try deleting and re-downloading the songs via the “Music” app.

Hi Diane,

Please also try deleting and re-downloading the songs in the Music app.

iOS7 beta 6 same problem

Bad news! So for me djay2 is not usable. Most of new bought songs are not loadable.

Hi Warren,
Thanks for the tipp! That works,

Not just you… I’m getting the same on my ipad 2 with iOS 7 beta

I am having the same problem on 6.1.3 on my iPad. I just made the app purchase a few days ago. ITunes purchased songs, iTunes matched songs, all local.

I tried this on every song that I had a problem with. And…it worked! Thanks for your quick response and help. I will be sure to make a comment when I Rate you… Excellent.