Can't load tracks from iTunes that loaded absolutely fine before

If I go into MY LIBRARY and chose random itunes tracks I most of the time get this error message:

COULD NOT LOAD TRACK

The operation couldn’t be completed. (OSStatus error -54.)

What does it mean and why does it keep happening?

The tracks are perfectly matched with the cloud and are on top of it downloaded and sit on the hard drive.

Hi Louis,

please see this Apple help entry on the Matched status:

Note that Matched means, iTunes is working with a “Matched” duplicate from Apple Music, not your local file.

Unfortunately there is no way for 3rd-party DJ style apps such as djay to play songs from Apple Music, Apple’s music streaming service. This also applies when songs are downloaded onto your device from Apple Music, as the downloaded files will be DRM-protected.

Hi Louis,

sorry for the misunderstanding here, the matched tracks, if purchased from another source (not Apple Music) are playable.

For further informations:
https://www.imore.com/how-check-if-your-macs-songs-are-uploaded-matched-purchased-or-apple-music-drm…

Regarding your playback error, can you send us an exemplary track which is causing the described error?

If you have any questions or suggestions, or if you would like further information, please don’t hesitate to contact us. 

Hi Louis,

I was not able to reproduce the issue, no matter from which Library an exemplary .m4a track was loaded, it played fine.

Can you please check if the track which is not playing is pointing to the right file by checking its source (Show in Finder)?

Thank you in advance.

Hi Louis,

thank you for the video.

Could you try to delete the track of the My Library playlists and add the same track via drag and drop to the playlist directly from iTunes?
After doing so, does the error persists?

Also are the tracks referring to the same track when you look for them in the finder?

If you have any questions or suggestions, or if you would like further information, please don’t hesitate to contact us. 

Hi Louis,

thank you for the video.

I forwarded this to our developers and we will do our best in order to find the reason for the problem as fast as possible.

that’s so bizarre.

I can load the same song if I chose to load it via the iTunes Playlist within DjPro 2, but NOT while in My Library or previous sessions.

They are both pointing to the same file if I chose “Show in Finder”.

Am I overlooking a conceptual flaw or is this a bug?

I understand that.

My issue is that they play perfectly fine when I chose to play them from within the iTunes tab in Dj Pro 2 but refuse to play if I play them in My Library/History.

So we are not talking about matched items then but rather unmatched ones. Locally, not copyright protected ones.

also, super important to understand my confusion:

Dj Pro 2 IS playing back my matched and purchased files!!!

see the attached pic & video.

https://www.dropbox.com/s/to9ugg8zvn2…

So, here’s another example of something feeling wonky and unpredictable in regards to tracks not being reliably found.

In this case the reference from DJ Pro’s internal playlist seems broken and I cannot load the track but when I try to load it from the internal Itunes search function/librarry it loads without problems.

see video & screenshot below:

https://www.dropbox.com/s/xqwpkc6fux8…

Lucas, have you been able to have a look at the screenshot and reproducible error message in the Video above?

bump! Any new isight on this? Still behaving erratically with tracks from iTunes. 100% Reproducible

Lukas or anyone else. Can u leet me know if you’ve been able to reproduce this. This is a recurring issue and highly problematic.

That’s so bizzare as it is 100% reproducible over here.

I recorded a video and put it up in this thread after your reply in regards to matched and bought songs. Please have a look at it as it will show you the issues in question, and yes, also that it’s pointing to the right file.

here is the link again for your convenience:

https://www.dropbox.com/s/xqwpkc6fux8…

Hi Lukas. Where you able to look at the video? do you need any more info?

If I do it as you’ve described above it works (deleting it from my music library then drag and dropping it from itunes onto the deck.

Here’s a video of what I’m constantly encountering but rather randomly with which tracks it affects:

https://www.dropbox.com/s/izxd96h3y4d…

bump! Did u get a chance to check the video and issue?