Can't play my own Spotify playlists (but others)!

Response when trying to open any of my own playlist is:
Error when loading music
—a reload icon—
403: You don’t have permission to perform this action.

I’m able to open subscribed playlist from other people and all other, but not my own (ever).

Have you tested following?:

  1. “Native” Spotify accounts (i.e. not through Facebook)
  2. Spotify accounts with characters like åäö in the username
  3. Passwords with foreign characters (I have an “ö” in mine)

When trying to connect Djay to my Spotify account through Chrome, it attempts to open a page with following URL: djay-iphone-2://spotify-auth?code=…
From an Android tablet (Nexus 7)!?

And yes, I’ve tried log off and in again and so on…

Is it possible to get some response!?

If I can’t use my own Spotify playlists, this application goes to trashcan!!


Is there a Djay2.2 with support for international characters in the near future?

Any response on this?

It was a bug within Djay2 for Android, which is solved in newer releases…

Have anybody got some response about this (Encoding-) bugs in Djay2’s code for the Spotify API?

How hard could it be to implement UTF-8 as Spotify says in their API-documention!?

Hi there,

sorry for the massive delay. Could you tell us with which version you are playing right now?

Lukas E.

I have exactly the same problem - there is no spotify section for playlists showing. I see that nobody has responded to Claes on this for over a year so I presume Algoriddm do not give a s*** about customer problems

I have managed to resolve this issue myself. Claes not sure if it was the same issue for you … but I had 2 instances of DJ Pro on my iMac somehow. If I open one of them I see the playlists but not on the other instance. That seemed to create the issue I guess.

This problem has been resolved now for both Claes and I now.

Thanks, Martin