Crossfader FX Ignores Auto-Transition Duration Settings & Double-Select UX Issue


In testing new Crossfader FX on djay 5.0.2 on iOS, I’m seeing no change when setting Auto-Transition Duration to most settings (2, 8, 16, 32, etc). It seems to only transition at 4 regardless.

I’m opening the Crossfader FX pop-up with 2 tracks playing on Decks 1 & 2, selecting 8 or 16 or 32 in Auto-Transition Duration, and finally selecting the Mix Now button. The result is always a 4 beat transition.

I know it worked at least once or twice because I watched it transition slowly after selecting 16. But now it only transitions at 4 beats always.

Force quit djay, restart iPad, and trying different songs and different crossfader effects.


It’s unnecessarily tedious to be forced to open the Crossfader FX popup twice if I want to select a new effect and then select the Mix Now button to use the effect.

With 2 songs playing on both decks, I open the Crossfader FX popup and select an effect like Riser. Immediately the popup closes and I have to reopen the Corssfader FX popup in order to start the desired Riser transition. It’s unexpected and requires a doubling of taps.

Maybe this is unimportant because most people will use one effect 99% of the time (if they ever use it at all). I’ll likely map this to a controller anyway, but it still seems like a poorly implemented user experience.

Hi @CliffyPop, please note that there are essentially 2 places now where you can set an auto-transition duration:

  1. In the new Crossfader FX menu at the bottom.
  2. In the Automix Settings under Duration.
  3. To simplify things for yourself, I recommend you set these to the same value.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.