crossfader jumps around on Mixtrack Platinum fx

The crossfader is basically unusable on the controller at the moment.

If the crossfader is close to either side it is jumpy. It is only stable and accurate in the middle.
This makes it unusable. I know its not the hardware cause I can load other DJ software with the same machine, cables and controller and it works flawlessly.

This does not happen in other dj software with this hardware so it is NOT a hardware problem.

This is on 3.1.7 of DJ Pro AI for the mac.

I should not have to use automix and have the sytem mix for me.

How can this be fixed?

Hi @Joel_Leggett,

Could you please open djay and go to the MIDI drop-down menu to the top of your screen. There you’ll be able to disable the “Cut-Crossfader” mode. Let me know if the issue persists.

Cheers, G