Custom MIDI Mapping (VCI-400 - no Pad Modes)

Hey there,

I’ve got a Vestax VCI-400 which is currently mapped to DJ Pro. However, the 8 PADS are mapped to loop / effects by default, and the 4 buttons to change between pages are also mapped to autoloop functions (this controller was designed like this).

Using MIDI Monitor, I’ve checked that the 8 pads are the same note and in the same channel whatever pad mode/page you are (old hardware design), so in terms of hardware, I’ve got only 8 actions to do (not 8x4=32).

Comparing into a Pioneer DDJ-400, when switching into a different page, the 8 pads are in a different note / channel so for the newest controllers every pad mode assign a different channel on the pads using hardware. (new hardware design)

I am wondering if some of you are used to XML files, so I’d like to create some conditions like “if pad mode = 1 then pads are these channels to map Hot Cues” , “if pad mode = 2 then pads are these channels to map Beat Loop”, and so on.

Virtual DJ has the VDJ Scripts which is cool for this kind of controllers, so you can create several conditions into a button / combination of buttons.

Thanks in advance!

@monkadj I used to have a Vestax VCI-400 and I was able to get the 4 Pad Modes working. I believe you simply need to update the firmware.

Here’s some additional info that should help:

Thanks for the reply!

Actually I’ve got the latest audio & midi firmwares and checked that thread also from DJ tech tools.

Are you sure you could have the 4 pad modes working on DJ Pro ?

Thanks once again!

@monkadj yes, I’m 100% positive I had 4 Performance Pad modes on my VCI-400. I know for sure because I made a custom MIDI mapping for them in djay Pro AI on iOS and MacOS.

1 Like

You should try the firmware recovery procedure then do the upgrade.

Hey @Slak_Jaw , I’ve tried it all.

I can restore the audio driver to 0x0600 version then I’m not able to restore either FW v1 or FW v2 from DJ Techtools. However, I’m able to restore/install the MIDI FW from Serato (versions 1.15 & 2.03).

When FW v1 or v2 I get ‘ACK is not found’. I’m researching on web but so far haven’t found anything helpful.

Thanks!

@monkadj that’s strange. Maybe you’ve got a faulty unit then. Have you tried with and without the Stand Alone Mixer Firmware?

I have two VCI-400s and was able to get them both working using those instructions. Unfortunately, they are both in storage in different countries right now so I can’t check which firmware they are using. Sorry I can’t be of more help. I know there are a few other djay users around using the VCI-400 as well.

Are you using Mac or PC? Maybe try installing from a different computer?

@Slak_Jaw No worries mate, you helped me a lot already!

I’ll continue working on it :slight_smile:

Tried with both standalone and no standalone firmwares. Using 2 PCs, an old one with Win7 and a newer one with Win10. (thinking about installing a vbox machine with winxp) but not sure if this is related with.

Tried on Mac but I’m not able to run the firmware app on Big Sur.

1 Like

Just to clarify, I see on the DJ TechTools they talk about VCI400SE (SE edition) which I’m not sure if it’s a different hardware model than the VCI400 which is the one I’ve got. If so maybe this is the problem, so they made 2 different versions.

Both of mine are the SE version. I’m pretty sure the only difference is different color scheme and the default firmware. Hardware component-wise I think they are identical

@monkadj just following up on this to see if you were able to get it working.

Hey there!!

Unfortunately I had no luck!

Impossible to update to FW1 or FW2. According to the DJ Techtools forums the VCI400 & VCI400SE are different designs in terms of hardware (it also says the VCI400 can’t get this update as it’s not the same model). I’m not sure if this is right because I’ve not seen anything else saying that but in the end my 400 can’t get that upgrade, so I’ve got the one available on Serato website.

Anyway I did some small mapping just to have the 8 performance buttons/pads to Hot Cues and the 4 pads next to play/cue below to the solo/mute stems. Still thinking what to map to the 4 “page mode” buttons, maybe loop roll or something useful from my side :wink:

Thanks for the follow up!

Hi @monkadj, thanks for the reply. Sorry to hear you couldn’t get that to work. Very strange. I always thought the hardware was the same except for the paint job. Still one of the best controllers for djay IMO though.

Also, are you aware that the 4 pads next to the Cue/Play buttons have multiple modes? There’s a switch on the front face of the controller to toggle between them.

Yeah I know changing those switches make those buttons go to a different MIDI channel :slight_smile:

This controller is still very functional nowadays even without this firmware upgrade!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.