DDJ-FLX4 not connecting

I recently upgraded my macOS to Sonoma 14.0. Since then, djay Pro AI is not recognizing my DDJ-FLX4 on my MacBook Pro.

I attempted to plug in another MIDI device (Akai MPK Mini) to test if djay Pro AI would recognize the device, and it did. My MBP does recognize the DDJ-FLX4 when it’s plugged into one of the ports, but NOT in djay Pro AI.

I can successfully use my djay Pro AI & DDJ-FLX4 with my iPad Pro. I’m able to connect via Bluetooth & USB-C with no issues.

DDJ-FLX4 firmware is up-to-date at version 1.03.

Before the upgrade, I was able to connect my DDJ-FLX4 with no issues. Could the new macOS Sonoma 14.0 causing a connectivity issues? Is anyone else experiencing the same issue?

@Michael_Mappala based on your explanation, it certainly sounds connected to MacOS Sonoma.

  1. Are you logged into your Mac with the same Apple ID that you purchased your djay subscription with?
  2. Try the suggestions in this Trouble Shooting Guide next: https://help.algoriddim.com/hc/en-us/articles/360022098980-Controller-Troubleshooting-Guide
  3. If the above suggestions don’t work, you could try uninstalling and reinstalling djay Pro AI on your Mac. Make sure you backup your files and djaymedialibrary before doing this though. https://help.algoriddim.com/hc/en-us/articles/360014912211-Where-does-djay-store-playlists-cue-points-and-other-data-

I appreciate the reply @Slak_Jaw.

  1. Yes, I am logged in on my Mac with same Apple ID that I purchased my djay subscription.
  2. Yes, I have tried the trouble shooting guide. I also downloaded the MIDI monitor app, and was NOT getting any response from the DDJ-FLX. My other MIDI device (MPK Mini) was recognized.
  3. I did trying installing and reinstalling djay Pro AI, but getting the same results.

I’ve also tried using different cable and still not connecting. Again, DDJ-FLX4 works with iPad Pro via Bluetooth/USB-C connection.

Could it be a driver issue? I know the PioneerDJ website that there’s no need to download drivers for this controller.

I downloaded djay Pro AI on another Mac and it was able to recognize my DDJ-FLX4. The other Mac was running on an older macOS. It seems like it’s more the DDJ-FLX4 connection to the my computer running on Sonoma 14.0 rather than djay Pro AI recognizing it.

I will try contacting Pioneer DJ to see if they can figure what is happening with the connectivity.

@Michael_Mappala sounds like you’ve tried all the suggestions I can think of right now. Seems directly related to your MacOS update. I also recommended you submit a support ticket to Algoriddim from within the djay app.

@Michael_Mappala I had the same issue. Searched and search, finally got the tip to upgrade to macOS Sonoma Public Beta 14.1… FIXED!

Depending on your tolerance for running a Public Beta version of an OS, at least you’ll be able to use your controller.

Good luck

1 Like

Welcome to the community and thanks for the tip @chicoricopico!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.