DDJ-REV7 Implementation Has Fallen Apart

Greets:
It’s been several weeks since I used the DDJ-REV7 with DJay Pro. I am planning to do a livestream on Wednesday, but I was taken aback last night when I found the MIDI implementation was not working properly. I did erased and restored my iPad Pro earlier this week, and since the install was fresh without using any backup files, I am at a loss to know what’s happened.

When I attached my iPad Pro last night, the left deck played fine and the controls for that side were working. I was loading a track on the right deck, but when I pressed play, the right deck was silent, with the channel fader all the way up and the crossfader to the right. However, when I move the crossfader tot he left, I then hear the song from the right deck play. Also, the buttons and controls that do not work on the playing right deck, the left controls do work for that deck. So other than loading and start/stop, it seems that the controls on the left work both both left and right decks.

I did check the Audio Device Setup, and it’s set to Internal, with Ch1-2 set for the master output.

I really would like to try and get this sorted before my livestream tis week, so any assistance to help me in that direction would be greatly appreciated.

Many thanks!

BTW, my iPad is on iOS 16.

1 Like

Hi @Velanche_Stewart,

Thank you for your message and I’m sorry to hear of the issues you are experiencing with djay and your controller!

This is a matter we are actively looking into, although in the meantime can you please give the following audio configuration setting a try?

I hope this information is helpful and if the issue persists feel free to reach back out to us!

Hello Andrew:
Thanks for the reply.

Based on my previous experience, I was able to figure out enough to enable some of the settings in the image you shared, and at that point the full right deck ended up working properly. I will set the rest of what’s in the image, later on.

I was able to do a livestream last Wednesday with the changes made, but one thing I ran into was that when I accidentally hit on one of the pads in sample mode, the sample volume on the controller did not work. I have not tried mapping it yet, but is it mappable? Or is there another location mapped on the controller where I can adjust the sampler volume?

I have faith that the REV7 mapping will come together; as it is, it’s working well so far.

Thanks much.

I have been having the same problem, but on iPadOS, 15.7. Will try the settings above and see if it works.

Hi,

I have now tried the latest Djay Pro 4.0.12 on iPad latest version with my Rev7 and still encounter some of the same problems. The faders don’t work as expected and the effects only seem to work on Deck 1 among other things.

B

Yeah hopefully, they will eventually make it so that things that first worked and then stopped working is less of a thing. In the meantime, you can go to Audio Output settings in Setup and make sure that Deck 1 is set to Ch. 1-2 and Deck 2 is set to Ch. 3-4 via the drop-down list of channels.

Okay, this inconsistency has to stop!

After using my REV7 at a gig last night via Serato, I reassembled my setup around it at home, and decided to use my iPad to test quickly, since it’s quicker than using my laptop. I have the current version of DJay Pro on iOS, and I have not used it since the previous version.

Once again, things went wrong. In Internal mode, only one side plays. I then have to change the audio input mode to external, and then have to set Deck 1 and 2’s outputs just to get the two decks to play. I also have to set the sampler and recording input, too.

These updates continue to knock out any previous settings that I have, and even if the REV7’s settings by DJay are internal by default, those default settings have lately been messing up the decks, usually with only the left deck selected and the right not.

At this stage, this should not be an issue to have to worry about, especially if one wants to play out professionally, or even to use it at home and not worry that an update is going to mess up current settings. This should not be a thing, and I really do hope that this gets sorted very soon.