DDJ-SX2 Default Troubleshooting

Heyo, working with the DDJ-SX2 and djay Pro AI and getting this strange setting as default. Whyy…

Summary:

  • TEMPO on deck isn’t correlated with the software.
  • Headphone cue isn’t working.
  • Tempo on Software begins at lowest setting (away from original)
  • Software levels all drawn completely down

See pic! Thanks for your response!

Have already reset the controller and reset software by inputing this “defaults delete com.algoriddim.djay-iphone-free” into terminal.

Hi @Big-Cat,

That is strange and isn’t something we’ve seen for default settings with this setup. I’ll be happy to help troubleshoot this. So we can take a closer look, could you please tell us the following:

  1. What device are you currently using?
  2. Which OS version is running on your device?
  3. Which djay version are you using?
  4. Have you already tried a complete fresh install of djay Pro AI on your computer? If not, please go ahead and do so.
  5. Do you have all up-to-date firmware and drivers for your controller (please check Pioneer’s website for this information)?
  6. Have you checked out our Controller Troubleshooting FAQ here:
    Controller Troubleshooting Guide – Algoriddim Support
  7. Does this default setting occur with all tracks or only some of them? If only some, have you noticed a pattern for which tracks this occurs with?

Thanks in advance for the additional information.

@Emily

I’ve just plugged in my SX2 following the latest update and all appears to work fine, so it doesn’t look as though the update broke something.

It doesn’t help @Big-Cat, but it does narrow it down to being something more local to his set-up.

:+1:t2:

1 Like