DDJ SZ-S problems with native support

Hello DJ pro team,.

i just upgraded from a SX to the SZ-S version of Pioneer’s DDJ and nothing has been working clean since

first, it didn’t even recognise the device… after a firmware update, if finally did recognise it however all the mappings are off…  the sliders were not assigned in the default mapping… i managed to map them myself thankfully… then , i tested it out… 

the 2nd deck sends the song to both channel 1 AND channel 2 when the channel 2 fader is up. this causes problems for obvious reasons. 

it also, always trys and set tthings to “external” mixer every time i reboot. 

is their a new pre-map for the model “S” which is really only a paint job from the standard SZ model. 

using MAC OS Catalina with latest update. 
thanks in advance for any help or guidance.

Hi, Just bought the DDJ SX3 and having all the same problems… Help Lukas!

won’t let me reconfigure. can’t pre cue. Although the lights flash for decks 3&4, stay permanently on for deck 1 and won’t come on at all for deck 2! 

Hi Vincenzo,

Thank you for getting in touch.

We are sorry to hear about this. The SZ is natively supported by djay Pro 2. Did you use the Pioneer Controller Manager to change the rooting of the Channels?

When you first used the controller did you initialised the controller with the Pioneer Controller manager?

Natively supported djay controllers don’t need further software setup, they can be used via plug and play.

Could you please change the channels used in the djay pop up window?

this program is going down hill fast, check my windows post about the ddjsr2 which algoriddim have no marked as not natively supported.

are you on mac or ios?

it really feels like algoriddim are persueing the ios version the most.

in case it wasn’t clear, what is actually happening is the output from deck 2 is being sent to both channel 1 AND 2 however the volume does’t output to my speakers unless the fader is also up for channel 1. 

really weird.


i tried re-installing DJ pro 2 completely… nothing changes. 

when i turn on the SZ, it doesn’t even prompt me to “use” the SZ nativly like it did with my SX. 

i have came to the conclusion that the SZ is no longer nativly supported by DJ PRO 2. 

any changes i can get the midi map file? most of the buttons either don’t work or are the root cause to the problem. 

Hello Lukas, thank you for your response.

i changed nothing in anything. 

when i first plugged the SZ, no pop up came on screen (as it did for my old SX) to “ask” me if i want to use this controller.  All it did was go directly to “External” mixer.

the first thing i noticed was that the faders didn’t work. then i went into settings in DJ PRO to Midi edit and added the faders. i also right away noticed that the midi maps were “missing” alot of the notes for this console.

i completly un-installed DJ PRO 2 and re-installed it fresh, re-plugged in my SZ and STILL same thing. 

my conclusion is that i would require the MIDI MAP for the SZ so i can add it to the DJ PRO folder and select it when i plug in my mixer.

nothing is working properly.  you can see my screen shots for clarity on how it’s setup currently and still not working.

when i press the “Cue” button on the consol, it actually outputs sound to a different channel, overlapping the sound from that channells fader… something is off here. 

as for “Pioneer software”, it doesn’t really do anything… all settings are defaulted to what i attached above. no “initialize” or anything required. 

thanks for any help.


i went ahead and formated my hard drive, re-installed DJ PRO 2, re-installed the updated pioneer Drivers, plugged in my DDJ SZ and STILL no “Pioneer” logo on the screen and mixer goes directly to “EXTERNAL”… same problems as listed above… 

it’s possible the latest Catelina update broke Native support ?

again, if i can JUST get the midi mapping file from you guys i’ll just add it manually and move along here.

side note : Serato works flawlessly with this exact same setup so the problem is with DJ PRO and the controller setup. 

2nd side note : Serato sucks and using it in the meantime makes the wait for a solution even worse. :D 

On a side note, a guy on the pioneer forums with the Ddj1000SRT is having this exact same issue as me. It’s a problem with DJ pro. Please help fix this issue with the software no longer recognizing our consols as native.

and just to be clear, when used in EXTERNAL mixer mode, it works flawlessly. 
as soon as i change it to internal mixer, all the problems start. 

seems like this issue is spread accross all controllers these days. i hope they issue an update that fixes everything.