DJ Pro AI on MacOS - Automix change next track but retain list

Hi everyone, I’m using DJ Pro AI on MacOS

I’m DJing an event where I need to play songs from start to finish, no need to mix, but with minimal silence between songs or even gentle overlap.

The set is prepped in advance but will also need to adapt to the moment or to requests. There will also be occasions where I will need to leave the booth for a couple of songs. So I setup a manual list automix, switch to two deck view and I’m good to go. When I’m at the booth, I can fade or blend the tracks with no issue and when I’m away it’s setup to minimise silence as much as possible and auto plays the next track when the other finishes.

My problem is that if I need to change the song that will be played next and drag a different track onto the second deck, the song that was queued there disappears from the Automix list completely rather then drops to third place in the list (1st place - currently playing, 2nd place - cued on second deck, 3rd place in the automix manual list.

On the iPad version the automix “up next” list has the 2nd place song - (which is cued on the second deck) listed first. Dragging a new song to the top of that list makes that song play next (2nd place)

On the MacOS version, the automix “up next” list has the 3rd place song listed first. Dragging a new song to the top of that list makes that song play third (3rd place)

Can the MacOS version please be updated to allow changing the next song and retaining the list order or is there something I’m missing that could make this work on MacOS?

Any help is greatly appreciated, thanks

1 Like

Hi @Peter2022,

Thanks for posting to the community for the first time!

Upon testing this situation myself, I discovered that in order for you to retain the song list order on the original playlist you were playing from, there are a few steps you will need to follow.

So let’s say you start your Automix from “Playlist A” and then want to add the requested songs.

First, you will go to the source in the Automix sidebar, then select “Manual”. From here you will add your requests as normal, although you will need to drag the first song from your manual list into the non-playing deck to command Automix to play from that list (I found this to work better and easier in the Pro mode view).

After this, your Automix will proceed through your requests in the manual list as normal.

Now, when it is time to return to “Playlist A”, you will first need to select your playlist in the library window, then drag the song that was up next prior to your request list into the non-playing deck.

After this is complete, your source in the Automix sidebar should now be back to “Playlist A”, and as long as you don’t select shuffle, the original tracklist order should be untouched.

I hope this helps and feel free to reach back out if there is any other way I can help!

Hi, that wasn’t what I was trying to do.

I’m not playing multiple playlists. I am playing from the “Manual” source in the Automix sidebar. I have 40 songs in that list.

Let’s say I started the automix and it’s played the first 5 songs in that list and is now playing song #6 on Deck 1 and automix has already put song #7 on Deck 2.

I now want to add one more song to that list, but I want it to play straight after song #6 so I drag the new song (song #41) from my source folder onto Deck 2. It queues up but now song #7 is gone (this is the problem!). When song #41 plays, automix will queue up song #8 on Deck 1 and continue.

The desired behaviour is that after I drag the new song (song #41) to Deck 2, that when it starts playing, song #7 is queued on Deck 1 and continues down the “manual” list.

So I think this is a bug on the MacOS version. on iPad version there is the option to change the “Up Next” song which works as intended.

1 Like