Dj Pro AI: video mixing on projector issue

I have a MacBook Pro running dj pro AI. and I want to start showing videos at gig
I have it hooked up with a hdmi out to the projector or tv screen and it shows my whole computer on the tv screen and when I select the middle screen on my Mac to enlarge the picture it does so… but I am unable to see my next videos on my computer to cue the next song unless I click the enlarge button again so it mirrors my computer again on the screen which is visable to the audience… what do I need to do so I can mix and cue videos like in classic mode so I can preview the video and its not showing on the big tv…please help me understand this… thank you

Hi @mychael412,

Thanks for joining our Community.

You can press on the Screen logo to the top right side of the video mix screen - below the Algoriddim logo:

Note: This button appears only when you have a second display connected to your Mac.

Then you’ll be able to select what screen you’d like to play the master video mix on.

Let me know if you have any other questions.

Cheers, G

hello, if you read my concerns. I have No issue with playing the video on the master screen … it shows up when I click the button you are talking about… but when I hit the button my whole screen on my MacBook is showing the full screen video as well… and I am unable to see my mixer and library any more … so I can’t mix the next video unless I click the little screen button again then it shows my mixer on my laptop screen but it also shows a mirroring of my whole screen of my laptop on the master screen and shows all three mini screens … I should be able to see my mixer and library on my computer screen while the master screen is playing the video and it does not allow me to do so

? My issue was not answered yet please read my concerns

This does not fix my issues I still cannot see my library or my mixer on my computer screen when then middle master screen is playing on enlarged position… please let me know what needs to be done to fix this issue.
Is there a number I can call?

Hi @mychael412,

Please note we do not offer support via phone. We kindly ask for your patience.

Could you please check that you don’t have the “Mirror” option turned on for your projector in the macOS settings?

To change these preferences, when your Mac is connected to a display, choose Apple menu > System Preferences, click Displays , then click Display Settings. Then right-click and select Extend Display. This will allow you to have two separate displays.

Screenshot 2022-01-21 at 14.04.32

Now everything should work in djay.

If you’re not running macOS Monterey, the settings might look different. For more information visit Apple’s Support page.

Hope I could help. Let me know if you have any further questions.

Cheers, G

1 Like