djay 2 doesn't detect WeGO4 on iPad Air 2

I’ve got djay 2 (v2.8.6), an iPad Air 2 (iOS 10.3.2) and a WeGO4 (firmware 1.0.0) and the djay 2 app doesn’t detect the iPad Air 2, no matter what I do. The WeGO4 worked with djay 2 on an iPad Mini 1 prior to getting the iPad Air 2.

In the iPad Air 2’s General Settings > About > DJ Controller, it can see the WeGO4 when it’s powered up.

I’ve tried uninstalling and reinstalling djay 2 many times using different combinations, such as with the WeGO4 on and off and disconnected from the iPad Air 2, and I’ve tried resetting the iPad Air 2 and am using the official cable that came with it. Despite all this, djay 2 either doesn’t detect the WeGO4 or it prompts that the WeGO4 is not a supported device. Rescanning for MIDI devices does nothing.

Any other ideas, as I’m close to writing this setup off and returning all the hardware whilst they are in their returns period?

Edit: I also tried djay free (v2.8.5) and that suffers the same issues.

Hey MarkyPancake,

we are very sorry to hear that you had to go through all this to make your WeGo work.
In the end we are thankful that you shared your experience which can be used as a possible solution for other users and therefore, I wanted to thank you.

If you are experiencing anything similar or if you have any questions or suggestions, or if you would like further information, please don’t hesitate to contact us right away. 

Cheers,Lukas E.

After trying more variations and continuing to scour the net for a fix, I’ve finally got it working.

The last thing I tried before I was going to give up was uninstalling djay 2, resetting settings on iPad Air 2, reinstall djay 2, connect iPad to the WeGO4 without power, connect WeGO4 to mains, power up WeGO4, open djay 2, and then finally the ‘Pioneer DJ’ logo appeared on the screen.

That was far more faff that it should be, and the lack of official acknowledgement and solutions was frustrating, especially considering I only set up the iPad from fresh this week and it has never been connected to any DJ controller before and today was the first time it was connected to the WeGO4.

Based on this experience, I certainly won’t be rushing to buy djay Pro.

Since performing my own remedial action, the connection between the two devices has remained stable.

It was just a really frustrating experience, especially as the hardware and software are compatible and should be plug and play. Also, the lack of official acknowledgement and solutions didn’t help.

Anyway, I hope this thread will help if someone else has the same issue.