Djay 2 for iPad not recognising WEGO4

I am using Djay2 (2.8.4) as well as on my iPad air 2 (IOS 10) and the app is not detecting my WEGO4 controller. I have installed MIDI wrench and cannot see any MIDI signals transferred.

Please advise.

Note - I am using a brand new iPad and WEGO controller both purchased only a couple of days ago.

Hey guys,

we are sorry to hear that.
Can you tell us how you are connecting your iOS devices with the WeGo4, with which cable are you doing so.

Lukas E.

I was able to resolve the problem by uninstalling the DJay pro app from my iPad, then reinstalling it.

Lukas - used the USB cable that came with my iPad to connect to the WeG04. Everything works fine now.

I wish I could help. I’m having the same problem with my new iPad mini 4 and WeGO 4. Help page says that my mac should not need to download a driver. I’m confused. Did you get any information so far?

I have the same issue with my iPad 5th gen. I have contacted pioneer and they said to uninstall and then reinstall and it should work. It hasn’t worked. How do I fix this?

Same here with ipad new 2017, but works on my iphone x. Reinstalled the app but didn’t worked, I only can get the sound from the controller but everything else doesn’t work((( in settings in MIDI section show no controllers

I’m having the same issues with my new iPad Pro 2017 and my Numark mixdeck quad.